Solid\Works

SolidWorks Education Edition 2009-2010
Installation Instructions

D7_§ Installation )
SolidWorks Guide
~




7S Installation

SolidWorks Guide )

4 )

This guide is intended only to assist the reader with installation of SolidWorks 2009-10 Education Edition.
TechSoft UK Limited shall not be liable for any loss or damage whatsoever arising from the use of any information or
particulars, or any error or omission, in this guide.

Trademark acknowledgments:

SolidWorks is a trademark of SolidWorks Corporation

RM CC3 and CC4 Network is a trademark of RM Education plc
Windows is a trademark of Microsoft Corporation

Printed: Nov 2009

- J

Copyright Details |




SolidWorks Guide

(p?g Installation )

J

-

-
CONTENTS

INtroduction ..ot 2
Preparation..............coooooiiiiiii e 3
Stand Alone Installation................co.cooiiiiiiiee e 5
Network Installation..................ooooooiiiiiiiiiii e 10
Step 1 - Obtaining a License File .........cccoiiiiiiiiiiiiiiiiiieeee 11
Step 2 - Installing the SolidWorks Network License Software....................... 15
Step 3 - Installing SolidWorks on Client Computers ..........cccceeeeeeveeenveeneenne. 22
Method 1 - Install from DVD .......ccooviiiiiiiiiieeeeeeee e, 22

Method 2 - Create a One Step Installer and install from this.................. 27

Notes for RM CC Network USers .............ccoociiiiiiiiiiiiiiiieeeeieeeeeeeee e 32
Further Notes and Troubleshooting....................cccocoiiiiiiiniiiiiie 42

~

- 1N



% Installation )
SolidWorks Guide )

4 )
INTRODUCTION

This booklet has been written to assist users when installing SolidWorks Education Edition 2009-10.

The installation should be straightforward on most systems. However sometimes problems can arise, either
through system issues, licensing issues, network issues, user error, etc. These problems may vary
depending on whether it is a new installation or an upgrade. In our experience it is much simpler and
quicker to avoid the problems in the first place, rather than to try to sort them out if things have gone
wrong. Hence, the reason for this booklet.

TechSoft strongly advise users to read through these notes, and to follow them carefully when
installing the software. This should minimise the chances of any problems occurring.

Additional information is available on the SolidWorks website, www.solidworks.com. Some of the more

popular links can be found at www.techsoft.co.uk/swresourcelinks.htm (or go to www.techsoft.co.uk,
then choose SOFTWARE > SolidWorks > Customer Support).

The following names of products have changed from SolidWorks 2008 to SolidWorks 2009:

SolidWorks 2008 SolidWorks 2009

SolidWorks 3D MCAD Software SolidWorks® Standard

SolidWorks Office Professional SolidWorks® Professional
SolidWorks Office Premium SolidWorks® Premium

PDMWorks® Enterprise SolidWorks® Enterprise PDM
PDMWorks Workgroup SolidWorks® Workgroup PDM
COSMOS SolidWorks® Simulation

COSMOS FloXpress SolidWorks® FloXpress
COSMOSFloWorks SolidWorks® Flow Simulation
COSMOSMotion SolidWorks® Motion
COSMOSWorks Designer SolidWorks® Simulation
COSMOSWorks Professional SolidWorks® Simulation Professional
COSMOSWorks Advanced Professional | SolidWorks® Simulation Premium
COSMOSM SolidWorks® Simulation Premium
COSMOSXpress SolidWorks® SimulationXpress
DWGseries SolidWorks® DWGseries

eDrawings SolidWorks® eDrawings®
eDrawings Professional SolidWorks® eDrawings® Professional

NEW FEATURES
Details of the new features available in SolidWorks 2009 can be found at http://www.solidworkslaunch.com

J
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PREPARATION

2. Locate your Serial Number (S/N). The number typically begins with 9710 (Network) or 9700/9701

3. Existing Users Only:

4. Existing Users Only:

5. Administrative rights are necessary on the local system in order to perform SolidWorks installation or

6. Most anti-virus applications are compatible with SolidWorks software and will not block its

~N

1. Verify that your system meets the criteria specified at www.solidworks.com/System_Requirements.
In particular note that the minimum RAM requirement is 1Gb. Although the software can be installed
and run on a computer with less RAM than this, it is likely to run too slowly to be practical.

(Stand Alone).

For New Users:
The serial number is located on the front of the box on a sticker and/or on your invoice/delivery note.

For Existing Users:

The serial number can be found from within SolidWorks by choosing Help > About SolidWorks. 1t can
also be located on the front of the original box on a sticker, and/or on your original invoice/delivery
note.

Back up all SolidWorks files (parts, assemblies, and drawings, document templates, sheet formats,
library features, and form tools) before upgrading to SolidWorks 2009. Files you open and save in
SolidWorks 2009 cannot be opened in earlier versions.

Choose whether to Upgrade or to Un-install, Clean-up and Re-install
Whilst upgrading an existing installation is the most straightforward to implement, please be aware that
many files from the old version will still reside on the computer after installation.

In order to minimise disk space, you should consider uninstalling your older Education Edition,
cleaning up, then using a new installation of SolidWorks 2009-10 Education Edition. If you do choose
this approach you will need to note the following:

a.  Before uninstalling any stand-alone copy of SolidWorks, you should transfer your license by
choosing Help > Transfer Licenses... from within SolidWorks.

b.  After uninstalling the main SolidWorks program, you should also uninstall all COSMOS
products, along with older versions of eDrawings, DWGEditor, etc.

c.  For a complete “clean-up”, the old registry keys will need to be deleted. Full details of how to do
this can be found at http://www.solidworks.com/sw/support/Tech Tips/TT CleanUpdate.html. If
the old registry keys are left in place, SolidWorks will default to the old folders for File Locations
and Default Templates (this is so that users do not think that they have “lost” their old work).
These folder locations can subsequently be changed from within SolidWorks using 7ools >
Options, but unless the user is made aware this, some confusion can result where old files are in
the SolidWorks 2008 folder and new files are in the SolidWorks 2009 folder.

upgrades.

installation. However, a few are not, and these will need to be disabled before SolidWorks is installed.
For a list of anti-virus products that have been tested for compatibility with SolidWorks installation and

J
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usage, please see http://www.solidworks.com/sw/support/AntiVirus_SW.html

Installation of SolidWorks can be done whether the computer is connected to the Internet or not.
However, many of the processes are automated if a live internet connection is available, so this is
strongly recommended.

SolidWorks includes a library of standard hole types and hardware. By default the library will be
installed into C:\SolidWorks Data. If you are doing a network installation you should consider placing
the library on a network share so that further upgrades, installations or additions to the library only
need to be done once on the shared folder. This can also be done when setting options for an
administrative image.

~
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STAND ALONE INSTALLATION

Installation of SolidWorks can be done whether the computer is connected to the Internet or not. However,
many of the processes are automated if a live internet connection is available, so this is strongly
recommended.

1. If you are an existing user, start up your current software and, after noting down your serial number
(see page 3, note 2), choose Help > Transfer License before upgrading or uninstalling (see page 3, note
4). This ensures that the nmber of activations is not exceeded.

2. Insert the SolidWorks 2009 DVD into your DVD drive. If the software does not start up automatically,
choose My Computer and click on the appropriate drive.

3. A Welcome Screen will appear.

Note:
[/ If you receive an error
LEAVE BLANK message about your serial
IF NOT KNOWN number, refer to Serial
Number Errors on page 42.
Help | Nex | -

For a new installation enter your serial number (just 16 digits, ignore the last two boxes); for existing
users the serial number may already be there. Click Next.

If you have only entered a 16 digit serial number, the last 8 digits will be automatically generated and
then presented to you. You should record the full 24 digit serial number then click Nexz.

4. If a later version of the software has been detected over the internet, you will be given the opportunity
to Download and install a new version. As SolidWorks is such a large piece of software, you are
STRONGLY ADVISED NOT TO DOWNLOAD, as download times for the full program can take
many hours. Choose Continue installing SolidWorks 2009 SP2.1 (the default) then click Next.

[0 SolidWorks 2008 SP2.1 Installation

Newer Version Available

7 Stand Alone Installation
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5. The SolidWorks Setup Wizard will guide you through the installation. Choose Individual for the
Installation Type and click Next. If applicable, choose your ‘Upgrade Option’ (see page 3, note 4)
and click Next to continue.

£ SolidWorks 2008 SP2.1Tr : {0 SolidWorks 2009 SP2.1 Installation Manager

Installation Type Upgrade Options

© Individual (on this computer)

) Administrative Image and Server products Read more
© | Create a new installation of Solidwarks 2008 SP2.1,

Note: For a new installation, some products will be upgraded if older versions exist. Click
Help for more infarmatian.

Upgrade SolidWorks 2008 to SelidWerks 2009 SP2.1,

T et

6. Accept the default settings on the following screen (if you do not have a live internet connection, you
must ensure that Solid Works Premium is first selected then add COSMOSM), click Next.

When the prompt asks you where you would like to put Hole Wizard and Toolbox Files, consider the
options available, further information is available by clicking on help. New users can accept the
default C:\SolidWorks Data or choose another location if preferred. If you are an existing customer
and would like to upgrade your current folder that contains the standard library files (SolidWorks
Toolbox, etc), click Browse and find the folder with your existing standard library files then click OK.
Existing customers can also choose to install new Hole Wizard and Toolbox Files if preferred by
Browsing to a new or empty folder.

After choosing your folder, click Next.

40 SolidWorks 2009 SP2.1 Installation Manager

TP: Click to expand and customize the install.

Hole Wizard and Toolbox
SolidWorks includes a library of standard hole types, as well as hardware if SolidWerks Toolbex is installed.
If you have multiple users, you may want to choose a central location for these files.

SolidWorks Premium -
Specify Hole Wizard and Teolbex file location:

Ci\selidworks Data

SolidWorks and Add-Ins (including Simulation products) (4.0 G8) (New installation)
SolidWorks eDrawings (80 MB) (New installation)
SolidWorks Viewer (42.M8) (Do not install) When choosing a location, consider the following:

DWGeditor (48 M) (Upgrade DWGeditor 2008 SP2.1)
Photoview 360 (0.49 GB} (New installation)

SolidWorks Explorer/Workgroup POM [0.15 G&) (Do not install)

COSMOSM (34 MB) (Upgrade COSMOSM 2008 SP2.0)
API Tools (15 ME) (Do not copy files)

- First time installing:
Browse to a new location where you would like to install.

- Upgrading:
Browse to your current file location to upgrade vour files. None of your data or custamizations will be lost,
but these files will no longer be compatible with previous major versions of SolidWorks. If you would like
Note: Required system components will be installed (0 KB): Microsoft VSTA. tmmakeiaibackumoon .ok helfiles; do'soibetoreiupgrading;

Note: Simulation installs appear under Solidworks/Add-Ins.
- Using two SolidWorks versions at once:
Copy your existing files to a new folder; then browse to the new folder to upgrade those files. This
installation of SolidWorks will reference the new files; and your previeus version will continue to reference
the existing files.

Installation Size: 4.7 GB

Install any new products to: C:\Program Files\Solidworks.
Next [ Next

J
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7. Ready to Install, click Install Now
There are a number of error messages that may appear during installation, depending on your choices
and currently installed software. Please refer to the Troubleshooting section at the end of this book if

further information is needed.

0 SolidWorks 2009 SP2.1 Tnstallatio

Ready to Install

Click Install Mow to begin, or Previous to change installation settings.

]} Postpone installation for hours.

| Provious {7 Install Now _;

8. Installation is Complete. Click Finish.

g0 SalidWorks 2009 SP2.1 Installatia

Installation is Complete

7] Check fer updates every 7 days.
Show me What's New in SolidWorks 2003.

Tell us how we can improve your installation experience (English only).

SolidWorks Customer Experience Program

You can improve the guality of Solidworks 2009 by sending encrypted fault and usage information te
SolidWorks Carporation. This infarmation is confidential and used for product improvement only. To learn
more, visit http://www.solidworks.com/pages/services/ProductFeedback.html.

7 Yes, I want to participate. (RECOMMENDED)
) Mo, I choose not to participate.

N.B. Depending on your computer configuration you may or may not need to restart your computer.

~
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will show. Click Next to continue.

SolidWorks Product Activation

Thanle you for installing SolidWorks. You must activate your
installation to fully enable all of the features. This wizard will guide
you through the activation process.

What would you ke to do 7

@i wart to activate my SolidWorks product now!

You can use this computer or another computer connected to
the intemet

) lwart to activate my SolidWaorks product later

p7 There are 20 dayls) left in your grace period:
SolidWorks

When this period ends, you must activate your SolidWorks product to
continue using it

10. To activate your SolidWorks product you must request a license key from SolidWorks. This can be

which you are installing the software is not connected to the Internet, it can be done manually via e-
mail.

Activate/Transfer Your SolidWorks Product

To activate your SolidWorks product you must request a license key from
SolidWarks. The Activation Wizard wil help you collect the information necessary ta
activate your product.

Product: | SolidWarks

How would you like to activate your SolidWorks product?
@ Automatically ov
' Manualy via e-mail

9.  When you start SolidWorks Education Edition for the first time, SolidWorks Product Activation prompt

done automatically by choosing Automatically over the Internet (recommended), or if the computer on

~N
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11. Fill in the appropriate fields then click Next.

Contact Information

X
il

* Required fields
Company name =
First Name * Last Name =
E-mail = Location of use *
Phone * Title = [Ownerf’PartnerfFre&dem v]
Shipping address =
City/Town = Country/Region = [Un'rted Kingdom ']
ZIP/Postal Code = StateCounty ~

What products do you design?

What industry best describes your company? [Seled V]
What is your primary responsibility? [Seled... ']
Before SolidWarks, what was your primary CAD package? [Seled... ']

(e ) e )

12. You have now registered your SolidWorks Education Edition. Click Finish.

'.0_' Activation/Peactivation Succeeded.

Cumently activated products:

Product Expiry
SolidWarks Premium Newver
SolidWorks Simulation Premium Mever
SolidWarks Flow Simulation Newver

2
2 « K

SolidWorks

i ETR e W

-
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The general procedure is to first install the SolidWorks Network License software (SolidNetWork License
Manager) and the dongle on the license server, then to install SolidWorks on each of the client computers.
LICENSE SERVER
/ ® Dongle
& ¥ ® SolidWorks Network
USB dongle / ‘ License Software
-OR- ”
Parallel port dongle
LICENSE CLIENTS
® Install SolidWorks Software
License clients
J

-1

Network License



% Installation

SolidWorks Guide

\__/

Step 1 - Obtaining a License File
1.  Go to www.solidworks.com and then click login.

2. Once you are in the page headed “Logins for SolidWorks Communities”, click SolidWorks Customer
Portal. This will direct you to the sign-in page for the customer portal.

3. [If you already have an account, enter your email address and password then proceed to step 7. To
create a new account, once you are in the sign-in page, on the right side of the page, click on Click here

to create a Sign-In account.

7
SolidWorks

Welcome to the SolidWorks Customer Portal

Already a member? Not a member?

Sign-in using your email address and password . L
Learn about the benefits of jeining

Language: English
guag g M # To create an account, click here

email Address:
Password :

Remember Me

Forgot vour password?

©2009 Dassault Systémes SolidWaorks Corp.
Terms of Use Privacy Policy Piracy Prevention

4. Enter your serial number in the box and click Next at the bottom of the page.

Logout | solidWorks Websites | English |+ |\i)y Help
)

SolidWorks

HOME MY SUPPORT REFERENCES FORUMS COMMUNITY
CP Registration - Check Serial Mumber:

Customer Portal

Check Serial Number

Please supply & setial number below and click "Mext". If you do not have a serial number, please
click the button labeled "l dont have a serial number at this time".

Serial Humber:

» [ 1 dont have & serial number at this time | [ Cancel |

‘When navigating through your account creation, please use the navigation buttons on the page. Using your standard browser navigation buttons will impact your ability to
complete the account creation process successfully.

-

Network License )
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After you have completed filling out your Serial Number, you will then be asked to verify your
information. After you have verified, click Yes, this information is accurate.

Logout | SolidWorks Websites | English |+ |\;E)j Help

Search
7
SolidWorks Customer Portal

HOME MY SUPPDRT REFERENCES FORUMS COMMUNITY
CP Registration - Yalidate Account Info:
Validate Account Info

According to our recards, the displayed infarmation is what has been entered as the company
associated 1o the serial number you have supplied. 15 this information accurate?

Account Hame: Solidworks Internal Access Activations
Address Line 1: 300 Baker Ave
Address Line 2 {if applicable):
Address Line 3 {if applicable):
City: Concord
State: MA
Zip: 01742-2131

Country: US4

# [ *res, this information is accurate | [ Mo, this information does not match my company information | [cancel |

‘When navigating through your account creation, please use the navigation buttons on the page. Using your standard browser navigation buttons will impact your ability to
complete the account creation process successfully.

Next, type in your email address in the box and click Next. Fill in the appropriate fields asked in the
next step. (N.B. You will not be able to move forward if you have not completed the required fields
which are indicated with a red asterisk.)

Logout | SolidWorks Websites | English |+ |".‘;‘.@ Help | Search

SolidWorks Customer Portal
HOME MY SUPPORT REFERENCES FORUMS COMMUNITY
CP Registration - Check Email Address:
Check Email Address

Plesse provide us with your e-mail address.

*Pleaze note that this e-mall address wil be where licensing informstion, ss weell s any
communication that is done through your Solichiorks Customer Portal account will be sent

*Email Address:

m—

When navigating through your account creation, please use the navigation buttons on the page. Using your standard browser navigation buttons will impact your ability to
complete the account creation process successfully.

Network License
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SolidWorks

HOME MY

Fl Open SR's
FQ My Profile
W@ Contact Us

Solidworks world 2008
Cne Minute Tech Tips

Salidworks Dermos

Then click Next.

2
2
SolidWorks

Offers from our Partners

Logout | Solidworks Websites | English v |® Help

7. You have successfully signed in to the Customer Portal. In order for Full Access to the portal, you
must Register your Products. Under My Support, click Register My Products.

Search

Customer Portal

SUPPORT REFERENCES FORUMS COMMUNITY

Welcome Johnny Kim, Solidworks Corp. Internal Access
Monday, May 19, 2008
Subseription contract valid through 12/31/2009

- Self-Service

hi.‘ My Support References
\ " s Knowledge Base = Systern Reguirements
= Enhancernent Requests = Hardware and Graphics
» Review SR's (Service Requests) » Registration and Activation
= Review SPR's (Bugs) = Adrnin Guides
w Fized SPR list = Documentation Central
= API Support = Tech Tips & Presentations

» My Products  Wehinars
l-p = Register My Products = Training
About Technical Support

?%ﬁ, Download v"" Community
\‘ { u Downloads and Updates ‘@ = Forums
= 3D Content Central = User Groups
= SolidWorks Labs » SolidWorks Express newsletter
= API examples = Solidwarks warld
» Educator Resources = Supplier Source

= Certification

Logout | SolidWorks Websites | English V|@ Help

Solidworks 2008 SP4.0
EW (Early wisibility) is
now available for
download,

Survey: What's your
swareness of Solidworks
Corparations Offerings?
Survey: Help shape your
SolidWorks community!
Mews: Solidworks
Manufacturing Metwork
announcement

Survey: POM feedback
for the future

Mews: Update to
Solidwarks KE
(Knowledge Base)

ons
Why am I prompted for
the SNL server
information when
installing a client fram a
Cne-Step

Why am I prompted to

insert disc 4 during rny

service pack installation
of 2007 Service Pac

I have Solidworks Office
Fremium or
COSMOSWorks
Professional/Advanced
Professional install

Why won't
Moldflowxpress be
available in Solidworks
2008 onwards?

Issue in Solidworks 2008
SP2.0 Czech Wersion

[

8. After you click Register My Product, you will have to enter your SolidWorks Serial Number in the box.
(The number typically begins with 9710 and is located on the front of the box on a sticker and/or your
invoice/delivery note. If you cannot find, or you have misplaced your number, please contact TechSoft.)

Search

Customer Portal

HOME MY SUPPORT REFERENCES FORUMS COMMUNITY

* Indicates required field

to the i ks gistration.
Please enter the serial number for the product you would ke to
redister.

*Serial Humber:

e i [coci|

~N
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9. Once you have entered your serial number, you will then be asked what version you have. Click the
icon next to the box to find your version and then click Next.

Logout | SolidWorks Websites | English | |\E)j Help [ | [search |
SolidWorks Customer Portal
HOME MY SUPPORT REFERENCES FORUMS COMMUNITY

* Indicates required field.
Please click .ldbut‘ton for the pop-up window and
then click 4  to zelect the Version you would like to register

*Version: |

—- (] [cocl]

10. The SolidWorks Network License File (.txt) will be emailed to you. You should receive this file in a
few minutes. (Note: SAVE THE NETWORK LICENSE FILE TO YOUR HARD DRIVE. You will
need this in Step 2.) Click Next.

Logout | SolidWorks Websites | English |v |"\":)j Help ! [search
SolidWorks Customer Portal
HOME MY SUPPORT REFERENCES FORUMS COMMUNITY

Product Licensing

Message:
The license file for your product has been emailed to you.

o] e —
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Step 2 - Installing the SolidWorks Network License Software

You must assign one computer (usually a server) to be your SolidWorks License Server. On this you must
install the SolidWorks Network License software (SolidNetWork License Manager) as follows:

Note:

* All previous License Managers must be removed from your computer before beginning the
installation of the new License Manager (ie., 2008 must be removed before installing 2009).

* The License Manager must be installed on the machine that will be used to distribute
SolidWorks licenses on your network.

* Your dongle (hardware lock) must be inserted on the machine where you will install your
License Manager and not any other machine.

* The License Manager for 2009 will license both SolidWorks and SimulationXpress (formerly
COSMOS) products. In addition it will license SolidWorks 2008 based EDU products. Older
versions of SimulationXpress will require the older SimulationXpress only License Manager.

N.B. Always install the SolidWorks Network License Software and dongle driver software DIRECTLY on
the server. Installing it using a remote desktop application such as Remote Desktop Connection, VNC,
Symantec pcAnywhere, has been found to cause problems in most cases.

1. If you have a PARALLEL SolidWorks dongle, fit it now. If you have a USB SolidWorks dongle, and
are installing SolidWorks for the first time, do not fit the dongle until instructed to do so.

2. Insert the SolidWorks 2009 DVD into your DVD drive. If the software does not start up automatically,
choose My Computer and click on the appropriate drive.

3. A Welcome Screen will appear. For a new installation enter your serial number (just 16 digits, ignore
the last two boxes); for existing users the serial number should already be there. Click Next.

—

‘Welcome to the SolidWorks 2009 SP2.1 Installation Manager

Serial number for standard, Premium, or

—_— Note:

from SolidWorks Corporationgnter thegfihere.

If you receive an error
LEAVE BLANK message about your serial

IF NOT KNOWN number, refer to Serial
Number Errors on page 42.

Note: information on SolidNetWork license is available here in the documentation .

Help Next

If you have only entered a 16 digit serial number, the last 8 digits will be automatically generated and
then presented to you. You should record the full 24 digit serial number then click Next.

~N
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Newer Version Available

(RECOMMENDED)

4. If a later version of the software has been detected over the internet, you will also be given the
opportunity to Download and install a new version. As SolidWorks is such a large piece of software,

you are STRONGLY ADVISED NOT TO DOWNLOAD, as download times for the full program can

take many hours. Choose Continue installing SolidWorks 2009 SP2.1 (the default), then click Next.

© Continue installing 2009 SP2.1 from this DVD. You ¢an update afterwards with a smaller download.

") Den't install using this DVD. Dewnload and install the full 2008 SP3.0 version.
Note: This option requires a large download. If you download the full new versien, you should retain
the source installation files on your computer for future updates.

Check to see what this upgrade includes.

You will be asked to choose what you would like to install. Choose Administrative Image and Server
Products, then ONLY have Install SolidNetWork License Server ticked. Click Next.

Installation Type

") Individual (on this computer)

n chosen]

© Administrative Image and Server products Read more...
["] Create or update an Administrative Image. (Note: Updates will create a new image.)
Create the image using default settings.

Use installation settings from an existing image.

[T 1nstall SolidWorks Workaroup PDM Server (vault) on this computer,
Install SelidNetWork License Server (distributed licensing) on this computer.

6. You are now ready to install the SolidNetWork License Manager, Click Next.

SR

Cancel

\
7

17Sniiqurks

15! SolicWaorks SolidNetWork License Manager Setup.

to the

License Manager Setup Wizard

continue, click Next.

and international treaties.

The Solidworks® Setup Wizard will instal Selidworks
SolidNetWork License Manager on your computer. Ta

VYARNING: This program s protected by copyright faw

Cancel

J
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You will be asked where you want the files to be installed. After you choose, click Next.

‘ﬁj’ SolidWerks SelidMetWork License Manager Setup ==
Destination Folders 7
Click Mext to install to these folders, or click Change to install to
different folders. p .
SolidWorks

Install SolidWorks Solidiet\Work License Manager to:

G C:\Program Files\SolidWorks Corp\SolidMetWaork License \%I

Manager

&
5

o
=
3

Cancel

8.  You will next be asked what language you want as your default. After you choose your language, click

Next.
‘E! SolidWorks SelidMetWork License Manager Setup ==
Custom Setup >
Select the program features you want installed. p
SolidWorks

Click on an icon in the list below to change how a feature is installed.

Feature Description

SolidWaorks SolidMetWork License
Manager

orks SolidNetWwork License

upported Languages

m

This feature requires 106KB on
your hard drive. It has 1 of 1
subfeatures selected. The
subfeatures require 29MB on your
hard drive.

9. Now you are ready to begin the installation. Click Install to proceed.

‘E! SolidWorks SelidMetWork License Manager Setup ==
Ready to Install the Program 7
The Wizard is ready to begin instalation. p
SolidWorks

Click Install to begin the instalation.

If you want to review or change any of your instalation settings, click Back. Click Cancel to
exit the Wizard.

=}
5
=
@

-
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10. To continue the installation, DO NOT change the location where The wizard will help you create or
edit the FLEXIm license file. Keep the server type at Single, and then click Next.

- SolidWorky

4rﬁ 5 = = o ;
== = SolidMetWork License File Wizard LI
verin| 7
Welcome to the SolidMNetWork License File
3
This wizard will help you create or edit the following FLEXIm license file:
Server Type
@ Single
| Solig! () Triad {a group of 2 servers managing a common license poal}
Solig i
Bac Nedt> | | Cancel Help

11. In this step of the installation, you will be given your server information. PLEASE NOTE the
Computer Name and Port Number. (You will need the Computer Name and Port Number in Step 3.)
Once you have written down your Computer Name and Port Number, click Next.

=3 SolidMetWork License File Wizard |i|

Note:

The firewall option refers to
a software firewall such as
‘Windows Firewall’. It is Computer Name:  Ispower12 e
highly likely that your
server will have some form
of software firewall enabled. et (B «
Please tick this option and
see the notes on page 43 Vendor Dasmon Port Number: 25725
about Network Licenses
with Firewalls.

Server Information

Afirewall is in use on this server

FLEXID=5-0d81f378 =

m
(=]

Al

<Back || Ned> | | Cancel Help

J

Network License
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12. You will now have to insert your SolidWorks Network License File that you obtained during Step 1.
(You were given a Network License File (.txt) during Step 1. This file was placed on your hard drive.)
Click Read to insert your Network License File.

ﬁ [SRTTT RS TT VWY - = 3 |
— 1 =@ salidNetWaork License File Wizard ) -
Il
Licenses:
Press Read... to enter or add license information from a file. 5
e [ Fead. [ Detai | [ Remove | |
Product Version Expire Date Ma. Licenses
q | m ¥
[/] Reread license file (gfter Finish).
< Back ][ Finish ] | Cancel Help

13. Click Browse and locate the Network License File that you have copied to your hard drive. Once you
have located your Network License File, click OK.

—e — |1

'ﬁ!p ST o — F=Trer o

-

1 2§ solidMetWork License File Wizard [ =
I
Licenses:
Press Read... to enter or add license information from a file. E

Read Licenses

[ Read.. | [ Detal | IlEmﬁC] -
1

Enter a file containing license information:

\Documentshenl_license_email bt Browse.

ak ] I Cancel l

. .

4 LI 2

Reread license file (zfter Finish).

< Back “ Firish ] [ Cancel Help

-

Network License
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information, click Finish.

-

ﬁp ot FET WY R

>
— =% SolidNetWark License File Wizard

I
Licenses:
Press Read... to enter or add license information from a file. c
T Read... [ Detail ] I Remove I
Product Version Expire Date MNo. Licenses
6 SolidWerks Premium 17.0 3 -dec-2099 20
eSDIidWDrks Fow Simulation 17.0 3 -dec-2095 20
OSDIidWDrks Simulation Premium 17.0 3 -dec-2099 20
0 SolidWerks Standard 17.0 I-dec-2093 20
' 0 Solid\Werks DWGEditor 17.0 Idec-2095 &0
I m 3

cali

[ « Back “ Finish J[ Cancel Help

- _ ~
f@ SalidWerks SolidNetWork License Manager Setup _— | 23 |

&

7 4
2

SolidWorks |

Completing the SolidWorks SolidMNetWork
License Manager Setup Wizard

The SolidwWorks Setup Wizard has successfully installed
SolidWorks Solidiet\Work License Manager. Click Mext
to axit the Setup Wizard.

14. Your Network License information will show up on the screen. Once you have looked over your

15. You are now finished installing the SolidWorks SolidNetWork License Manager. Click Finish.

~N

J

O
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Server Installation Complete

& SolidNetWork License Manager: Installation successful.

o |

-

~

Network License
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Step 3 - Installing the SolidWorks Software on each Client Computer

There are now two ways to proceed. You can either simply install SolidWorks on each computer from the
DVD, or you can create a one-step installer (administrative image) on the server and allow each client
computer to use this to install from.

Method 1 - Install from DVD

This must be done on each computer that you wish to run SolidWorks on.

1. Insert the SolidWorks 2009 DVD into your DVD drive. If the software does not start up automatically,
choose My Computer and click on the appropriate drive.

2. A Welcome Screen will appear.

‘Welcome to the SolidWorks 2009 SP2.1 Installation Manager

Serial number for Standard, i Premium, or License

Note:
STVRER— m— .
/I If you receive an error
LEAVE BLANK message about your serial
IF NOT KNOWN number, refer to Serial

Number Errors on page 42.

Help Next ~

For a new installation enter your serial number (just 16 digits, ignore the last two boxes); for existing
users the serial number may already be there. Click Next.

If you have only entered a 16 digit serial number, the last 8 digits will be automatically generated and
then presented to you. You should record the full 24 digit serial number then click Next.

3. If a later version of the software has been detected over the internet, you will be given the opportunity
to Download and install a new version. As SolidWorks is such a large piece of software, you are
STRONGLY ADVISED NOT TO DOWNLOAD, as download times for the full program can take
many hours. Choose Continue installing SolidWorks 2009 SP2.1 (the default) then click Next.

[0 SolidWorks 2009 5P2.1 Instaliation

Newer Version Available

~

J

O
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4. The SolidWorks Setup Wizard will guide you through the installation. Choose Individual for the
Installation Type and click Next. If applicable, choose your ‘Upgrade Option’ (see page 3, note 4)
and click Next to continue.

§fJ SolidWorks 2009 SP2.1 Tnstall

£10 SolidWorks 2009 SP2.1 Installation Mar (SN X )

Installation Type Upgrade Options

© Individual {on this computer)
) Administrative Image and Server products Read more,
(0 Create a new installation of SelidWerks 2009 SP2.1.

Note: For a new installation, some products will be upgraded if older versions exist. Click

Help for more information.

* Upgrade Solidworks 2008 te SolidWorks 2009 SP2.1.

Help TR i Cancel Help | Next Cancel
! |

5. Accept the default settings on the following screen (if you do not have a live internet connection, you
must ensure that Solid Works Premium is first selected then add COSMOSM), click Next.

B e =
P
SolidWorks

TIP: Click to expand and customize the install.

SolidWorks Premium -

olidworks and Add-Ins (including Simulation products) (4.0 Ge} (New installation)

olidWorks eDrawings (30 ME) (New installation)

olidWorks Viewer (42 v} (De not install)

WGeditor {48 M) (Upgrade DWGeditor 2008 5P2.1)
hotaView 360 (0,49 GB) (New installation)

olidworks Explorer/Workgroup PDM (0,15 Gg] (Do not install)

0SMOSM (34 MB) (Upgrade COSMOSM 2008 SP2.0)
PI Tools (16 ME) (Do nat copy files)

Note: Required system components will be installed (0 KB): Microsoft VSTA.

Note: Simulation installs appear under SolidWorks/Add-Ins.

Installation Size: 4.7 GB.

Install any naw products to: C:\Program Files\Solidworks
o

-

~

Client DVD Install
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6a. If you are presented with the following screen (if the computer you have installed SolidWorks on is not
the license server). Click Add.

p— -~ J—

w;\? e — N — - =
NOTE:
List of license servers that can be accessed from this computer:
l | If you are installing as
fl" ' an upgrade to an
I existing installation of
! 975 — SolidWorks, it is

SolidWorks possible that the server
‘ name will already be

|[NFLEX!7Z} ‘ included in the dialog
box
|

b. Enter your license server and the port number that you specified in step 2-9, page 18. The default port
is 25734. Enter it as portNumber@computerName. Then click OK.

SolidWorks Installation Manager s ]

Specify the SML Server Location.

Enter Port@Host {e.g. 25734@myserver. Separate multiple entries with
semicolons).

If you cancel, you will be prompted during installation.

SML Server: 25734@tspawer 12

— o

c.  You should now see your license server listed in License administrator. Click OK.

. . . I
— o
29 SolidNetWork License Administrator PEE— =5
— -

List of license servers that can be sccessed from this computer

25734@tspower 12
0]
]
SolidWorks
IRFLEX!G7N 1

=

J
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/7. When the prompt asks you where you would like to put Hole Wizard and Toolbox Files, consider the A
options available, further information is available by clicking on help. New users can accept the
default C:\SolidWorks Data or choose another location if preferred. If you are an existing customer
and would like to upgrade your current folder that contains the standard library files (SolidWorks
Toolbox, etc), click Browse and find the folder with your existing standard library files then click OK.

Existing customers can also choose to install new Hole Wizard and Toolbox Files if preferred by
Browsing to a new or empty folder.

After choosing your folder, click Next.

[0 SolidWorks 2009 SP2.1 Installation Manager Ll S

Hole Wizard and Toolbox

SolidWorks includes a library of standard hole types, as well as hardware if SclidWerks Toolbox is installed.
If you have multiple users, you may want to choese a central location for these files.

Specify Hole Wizard and Teolbex file location:

Casoldworks ata

When choosing a location, consider the following:

- First time installing:
Browse to 3 new location where you would like to install.

- Upgrading:
EBrowse te your current file location to upgrade yeur files. None of your data or custemizations will be lost,
but these files will no longer be compatible with previous major versions of SolidWarks. If you would like
to make a backup copy of the files, do so before upgrading.

- Using two SolidWorks versions at once:

Copy your existing files to a new folder; then browse to the new folder to upgrade these files. This
installation of SolidWorks will reference the new files; and your previeus version will continue to reference
the existing files.

[ Freioss [ |

6. Ready to Install, click Install Now.

There are a number of error messages that may appear during installation, depending on your choices

and currently installed software. Please refer to the Troubleshooting section at the end of this book if
further information is needed.

Ready to Install

Click Install Now to begin, or Previous to change installation settings.

[7] Postpone installation for hours.

-

Client DVD Install
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8. Installation is Complete. Click Finish.

) SolidWorks 2008 SP2.1 Installation Man. X

Installation is Complete

7] check for updates every 7 days.
Show me What's New in SolidWorks 2009.
Tell us how we can improve your installation experience (Enalish only).

SolidWorks Customer Experience Program
You can improve the quality of SolidWorks 2009 by sending encrypted fault and usage information to

SolidWorks Corporation. This information is confidential and used for product improvement only. To learn
+//www.solidworks.com/pages/services/ProductFeedback.html.

maore, visit hit;

() ¥es, I want to participate. (RECOMMENDED)

) Ne, I choose not to participate.

[ F |

N.B. Depending upon your computer configuration you may or may not need to restart your computer.

J

Client DVD Install
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Method 2 - Create a One-Step Installer and install from this

You create a One-Step installer (administrative image) on the server and then allow each client to use this to
install from. (This method is ill-advised when using an RM CC3/4 network - see Notes for RM CC3 and
CC4 Network Users, page 32.)

1. On the server, insert the SolidWorks 2009 DVD into the DVD drive. If the software does not start up
automatically, choose My Computer and double click on the appropriate drive.

2. A Welcome Screen will appear. For a new installation enter your serial number (just 16 digits, ignore
the last two boxes); for existing users the serial number should already be there. Click Next.

&0 SolidWorks 2009 SP2.1 Installation

to the i 2009 SP2.1 i g

sssss | standard, Premium, or Soli

Note:

from Solidworks Corporationgnter therghere,

If you receive an error
message about your serial

}‘Fl?ﬁ\(;? ?{I&%I\‘I;,(N number, refer to Serial
Number Errors on page 42
Fil = -

If you have only entered a 16 digit serial number, the last 8 digits will be automatically generated and
then presented to you. You should record the full 24 digit serial number then click Next.

3. If a later version of the software has been detected over the internet, you will also be given the
opportunity to Download and install a new version. As SolidWorks is such a large piece of software,
you are STRONGLY ADVISED NOT TO DOWNLOAD, as download times for the full program can
take many hours. Choose Continue installing SolidWorks 2009 SP2.1 (the default). Click Next.

5 SolidWorks 2008 SP2.1 Tnstalletion

-

7 One Step Installer )
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Installation Type
" Individual (en this computer)
@ Administrative Image and Server products  Read more

Create or update an Administrative Image. (Note: Updates will create a new image.)

[No |ocation chosen]

@ Create the image using default settings.

) Use installation settings from an existing image.

[T 1nstall SolidWorks Workgroup PDM Server (vault) on this computer,

-

Choose a directory in which to install the administrative image (all client computers will need access to

this directory.)

4.  You will be asked to choose what you would like to install. Choose Administrative Image and Server
installation, then ONLY have Create or update an Administrative Image ticked.

After you have clicked Next, the SolidWorks Setup Wizard will guide you through the installation.

Accept Defaults on the following screen. Click Next to continue installation.

SolidWorks Premium

TIP: % =) Click to expand and customize the instal

Solidworks eDrawings (80 M2)

Geditor (0,13 GB)
toView 360 (043 GB)

API Tools (15 g,

Space needed for this installation: 5.2 GB .

® Solidworks and Add-Ins (including Simulation products) (4.2 Ge)

Solidworks Search, Windows Desktop Search (5.0 M8)

idworks Explorer/Workgroup PDM (0,16 G&

Note: Simulation installs appear under SolidWorks/Add-Ins.

[]: show products not included in serial numbers entered.

(Do not copy files)

~N

J
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7. Enter your license server and the port number that you specified in Step 2-11, page 18. The default
port is 25734. Enter it as portNumber@computerName. Then click OK.

8.

TIp: %‘ ~ | click to expand and customize the install.

SolidWorks Premium| sofidiorks Instalztion Manager B3]

= Specify the SNL Server Location.
e SolidWorks and A | Enter Port@Host (2.0, 25739@myserver, Separate multiple entries with
SolidWorke eDraf | scmicolons)
olhdWorles €Dral | 1 Lou cancel, you will be prompted during instalation
|& -] SolidWorks Sear
DWGeditor (0.19]
SN Server: 25734@tspower 12
Fhotoiew 360 (i

SolidWorks Expl )

-
Mote: Simulation installs

[T show products not included in serial numbers entered.

Space needed for this installation: 5.2 G5B .

® = -] AP1 Tools (15 wd ile<)

Over the next few screens you are required to set options for the Administrative Image. Detailed
information is available for each screen by clicking on help. Additionally you can edit these settings at

a later date if required (see point 12).

Administrative Image Location

Choose location for new Administrative Image (7.3 GB space required):
Note: Location cannot contain an existing Administrative Image.

Ci\Solidworks AdminiSolidworks 2008 SP2.1

Administrative Inage Options

["] create a diagnostic log during each installation. (slower)
[71 Run the installation as a different user:
Use this when updating client computers that do not have administrative privileges.
Login {Domain\User): Password:
] run a program before installation:

[No file chosen]

[7] Run a program after installation:

[No file chosen]

Client path for NEW installs. Upgrades will use existing client path (5.2 GB free space required):

Ci\Program Files\SelidWorks Corp

5 Cancel

One Step Installer

~N
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SolidWorks Client Install Options

Existing
© Upgrade |atest major release installation to new release.
_ Create new release installation (preserving previous major releases).
Note: Minor releases (Service Packs) will be upgraded. Products sther than

SolidWorks may be upgraded or installed new, depending on their version.
Click help for more information.

SolidWorks Settings

@ Use Solidworks 2009 default settings.
_ Use a settings file exported from the Copy Settings Wizard:
osen]

No file
SolidWorks Customer Experience Program

@ Yes, I want to participate. {(RECOMMENDED)

) No, I choose not to participate.

9.  When the prompt asks you where you would like to put Hole Wizard and Toolbox Files, consider the
options available, further information is available by clicking on help. New users can accept the
default C:\SolidWorks Data or choose another location if preferred. If you are an existing customer
and would like to upgrade your current folder that contains the standard library files (SolidWorks
Toolbox, etc), click Browse and find the folder with your existing standard library files then click OK.
Existing customers can also choose to install new Hole Wizard and Toolbox Files if preferred by
Browsing to a new or empty folder.

After choosing your folder, click Next.

Hole Wizard and Toolbox
Solidworks includes a library of standard hole types, as well as hardware if Solidworks Toolbox is installed.
1f you have multiple users, you may want to choose a central location for these files.

Specify Hole Wizard and Toolbox file lacation:

WTSPOWER12\Public\PublicSolidworksLibraryFiles

When ing a location, ider the

- First time installing:
Browse to a new location where you would like to install.

- Upgrading:
Browse to your current file location to upgrade your files. None of your data or customizations will be lost,
but these files will no longer be compatible with previous major versions of SelidWorks. If you would like
to make a backup copy of the files, do so before upgrading.

- Using two SolidWorks versions at once:
Copy your existing files to @ new folder; then browse to the new folder to upgrade those files. This
installation of Solidworks will reference the new files; and your previous version will continue to reference
the existing files.

J

One Step Installer
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10. Ready to Install, click Install Now.

§f SolidWorks 2008 SP2.1 Installafion Manage

Ready to Create Image

Click Create Now to begin, or Previous to change settings.

[7] Postpone creation for hours.

Create Now |

Frouous || Create o

11. The image will now be created.

12. Once the image has been created, install SolidWorks on each client computer using the
“StartSWlnstall.htm” file which you will find on the server within the directory you have just created.

N.B. The options chosen on the previous screens including Client Install Options, SolidWorks settings,
Administrative Image Location, Image options etc. can be changed at any time using the Admin Option
Editor. If you wish to do this, navigate to the folder where you made the image, find the html
application file named StartOptionEditor and double click it. Click on ‘Start Admin Option Editor’.

Y i
<¢ SolidWorks Admin b SolidWorks 2008 SP21 »

Gusl

Organize Ope f/ Sharing Settings (@ Bum

Name 2 Date modified Type Size

A SelidWorks Metion 28/04/20091649  File Folder
SolidWorks Simulation  28/04/20091650  File Folder
B Pictures WDS_2K3_X86 28/04/200916:50  File Folder
B Music WDS_2K3XP_x64 28/04/200916:50  File Folder
& Recently Changed WDS_XP_X86 28/04/2009 16:50 File Folder
'E Searches ‘Windowslnstaller 28/04/2009 16:50 File Folder

Public [ AdminDirector 02/06/20081847  Compiled HTML TLKB

= AdminDirector 24/04/200914:50 XML Document 502 KB

[=JstartOptionEditor 20/04/200914550  HTML Application 13Kk8 L
[Fymes LTMI Arniication ipplication 3KkB

s SolidWorks Option Editor

-

Getting Started
Add a new machine

Using groups

Saving option editor information

Recommended practices

Launch the Admin Option Editar 0] ption Ed itor
Help decumentation

SolidNetWoark License documentation

Start Admin Option Editor

Exit

-

7 One Step Installer
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Notes for RM CC3 and CC4 Network Users

IMPORTANT - ALL USERS

In order to run SolidWorks successfully on a RM CC3 or CC4 Network, it may be necessary to edit the RM
Software Restriction Settings. It has been found that a problem occurs if the RM network permissions do
not let non-admin users copy a temporary licence file to c:\docs & settings\username\local settings\temp.

To allow this file to be written do the following:
1.  Open RM Management Console

2. For CC3: Open Configuration Settings folder and click on Software Restriction Settings.
For CC4: Choose Software > Software Restriction Policies.

3. Ensure that Path Rules is selected.
For CC3: Right click anywhere in the right-hand pane and select Add new path rule from the pop-up
menu.
For CC4: Click Add in the top right hand corner.

4. In the Path: box type the following:
Youserprofile%\local settings\temp\solidworkslictemp.*

5. Ensure that Allow files in this path to be run is selected then enter a meaningful description.
6. Click OK to create the new rule then reboot the workstation to apply the new GPO.

7. SolidWorks should now run for all levels of users.

A special thank you to Mr lan Munro, ICT Manager at Simon Balle School in Hertfordshire who discovered
this.

INSTALLATION

Network installation can be carried out as described in this user guide provided Method I - Installation
Jrom DVD is used.

Unfortunately, due to the installation restrictions within an RM CC3 or CC4 Network, you are advised not
to use Method 2 - Create One Step Installer and install from this.

For those who wish to install the software using msi packages, we are very grateful to Mr lan Liverton at
Beths Grammar School in Kent, who successfully installed SolidWorks 2008 Education Edition on their
RM CC3 Network, and, more recently, SolidWorks 2009 Education Edition on their RM CC4 Network. He
has provided us with the following notes (some of which have been adapted after consultation with RM):

J

\__
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Setting Up the Pre-requisite Microsoft Packages

SolidWorks 2009 requires other packages to be available. These are the Microsoft Visual C++ 2005 Runtime, Microsoft .net
Framework version 3 or higher and Microsoft VSTA 2005 (Visual Studio Tools for Applications). The first two will usually have
already been installed under CC4. If all three are already installed on all your computers, then please proceed to Creating the
Main SolidWorks Package, page 34.

The following details how to obtain the Microsoft.net Framework 3.5 from RM. It also details how to make the other two
Microsoft packages if you are unable to obtain them from RM.

Microsoft .net Framework 3.5

If you do not already have it, the Microsoft .net Framework 3.5 package can be obtained from RM. Logon to the RM Support
website and load article DWN1460168 from the knowledge library. Follow the instructions provided.

Microsoft Visual C++ 2005 Runtime

To make a package for Microsoft Visual C++ 2005 Runtime:
 Insert the SolidWorks DVD
¢ Browse to DVD then PreReqs\VCRedist\vcredist_x86.exe
* Copy this file to any temporary folder, eg., C:\temp
¢ Create a new temporary folder, eg., C:\temp\V CRedist
¢ Open up the command prompt (Start > Run > cmd, or in Vista Start > Start Search) and type:
C:\temp\vredist_x86.exe /C
¢ Browse to the new folder you created , eg., C:\temp\VCRedist
* Open RM Application Wizard
¢ Select Manage a Windows Installer Package then click Next.
e Select Add an existing Windows Installer Package then click Next.
* Enter a name and description as follows:
Name: Microsoft Cplus plus 2005 Redistributable
Description: Microsoft Cplusplus redistributable (sourced from SolidWorks 2009 Install DVD)
e Under Package file (MSI) location, browse to C:\temp\VCRedist\vcredist.msi then click Next

Microsoft VSTA (Visual Studio Tools for Applications)

To make a package for Microsoft VSTA:

e Open RM Application Wizard

* Select Manage a Windows Installer Package then click Next.

e Select Add an existing Windows Installer Package then click Next.

* Enter a name and description as follows:
Name: Microsoft VSTA 2005 Redistributable
Description: Microsoft VSTA redistributable (sourced from SolidWorks 2009 Install DVD)

e Under Package file (MSI) location, browse to the SolidWorks DVD, then PreReqs\VSTA\vsta_aide.msi, then click
Next

-

~
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Creating the Main SolidWorks Package

On any machine:
* Insert the DVD
¢ Open a command prompt by going to Start>Run>cmd (or in Vista Start>Start Search). Run the following
commands:
o <drive letter>:
o cd swwiNdata\
o msiexec /a English_i386_SolidWorks.msi
¢ This will launch a wizard
¢ Click Next
e Select SolidWorks Office Premium, click Next
¢ Enter the serial number, click Next
 Enter a path (eg., OQ:\Applications\SolidWorks 2009\) and click Install
e The data will then be copied to the folder (this will take about 30 mins)
¢ When this has finished, click Next to close the wizard and return to the command prompt.

Run the following commands filling in your own details for the items in red (ie., serial number, port number and
computer name that you specified in step 2-11, page 18):

(N.B. A fuller explanation of each command can be found by visiting www.techsoft.co.uk and clicking on the
following links: Software > SolidWorks > Customer Support > SolidWorks Installation and Administration
Overview > Installation (Deploying Multiple Installations) > Command Prompt Deployment > SolidWorks feature
(ADDLOCAL parameter) or > SolidWorks global (other parameters)

o 0O:

o cd Applications\SolidWorks 2009

o SwCreateMST.exe English_i386_SolidWorks.Msi INSTALLDIR="C:\Program Files\SolidWorks"
SOLIDWORKSSERIALNUMBER="9710 XXXX XXXX XXXX"

ADDLOCAL=English,SampleFiles,Manuals, RealViewGraphicsdisplay,SolidWorks, Feature Works, InstantWebsite, Ph
otoWorksRender,ScanTo3D,SolidWorksAnimator,SolidWorksDesignChecker,SolidWorksRoutedsystems,SolidWorksT
oolbox,SolidWorksUtilities, TolAnalyst, CircuitWorks, DWG Partner, CoreSolidWorksTaskScheduler, ExampleFiles,Hel
pFiles,Intel_Modules_AgeiaX86 ENABLEPERFORMANCE=0 INSTALLWDS=0
SERVERLIST=25734@ComputerName OFFICEOPTION=3

Note you will need to change 25734 @ ComputerName to your own port number and computer name that
you specified in step 2-11, page 18.

e This will create an English_i386_SolidWorks.mst file in O:\. Move this file to Q:\Applications\SolidWorks 2009\
e For CC3:
Edit the file Q:\Applications\SolidWorks 2009\SolidWorks 2009.ini and add to the end of the file the lines:

WITransform=English 1386 SolidWorks.mst
Dependencies=Microsoft VSTA 2005 Redistributable, Microsoft Cplus plus 2005
Redistributable

For CC4:
e In O:\Applications\SolidWorks 2009\ create a file called SolidWorks 2009.ini with the following content:

[Package]

WIPackage=English 1386 SolidWorks.msi

Description=Package for SolidWorks 2009 SP2.1

0S=5.WS

WITransform=English 1386 SolidWorks.mst

Dependencies=Microsoft VSTA 2005 Redistributable, Microsoft Cplus plus 2005
Redistributable

(Microsoft VSTA 2005 Redistributable, Microsoft Cplus plus 2005 Redistributable
assumes the use of the packages created on previous pages - adapt as appropriate).

J
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o If this is a new install, in RM Management Console:
For CC3:
o Update the package list
o Open the Configuration Settings folder
o Go to Software Restrictions Settings
o Ensure that the Path Rules radio button is selected, then right-click anywhere in the right-hand pane and select
Add New Path Rule from the pop-up menu

o In the Path box type: ‘ Suserprofile$\local settings\temp\solidworkslictemp.* ‘

o Ensure that the Allow files in this path to be run radio button is checked, and enter a meaningful description
o Click OK to apply the rule

For CC4:
o Go to Software > Software Restriction Policies
Ensure that the Path Rules radio button is selected.
Click Add in the top right hand corner
In the Path box type: ‘ $userprofile%\local settings\temp\solidworkslictemp.* ‘

o
o
o
o Ensure that the Allow files in this path to be run is selected in the drop down list, and enter a meaningful

description.
o Click OK to apply the rule

* For all installs, in RM Management Console:
For CC3:
o Update the package list
For CC4:
o Go to File > Import > Package
o Choose Community Connect 3 Package
o Click Browse
o Select the SolidWorks 2009.ini you just created
o Click Open
o Click OK. (Be patient- the package may take some time to import).

-
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Creating the DWGEditor and eDrawings Packages

DWGEditor
On any station:
¢ Insert the DVD
e Open a command prompt by going to Start>Run>cmd (or in Vista Start>Start Search). Run the following
commands:
0 <drive letter>:
o cd DWGeditor
o msiexec /a DWGeditor.msi
e This will launch a wizard. Click Next
» Enter a path (eg., Q:\Applications\SolidWorks DWGEditor 2009) and click Install
e The data will then be copied to the folder (this will take a few mins)
¢ When it has finished, close the wizard
e For CC3:
Edit the file Q:\Applications\SolidWorks DWGEditor 2009\SolidWorks DWGEditor 2009.ini and add to the end of
the file the lines:

Addcommand=INSTALLDIR="C:\Program Files\DWGEditor" DWGASSOC=1 LICENCETYPE=2
SERVERLIST=25734QComputerName
Dependencies=SolidWorks 2009

For CC4:
Create the file Q:\Applications\SolidWorks DWGEditor 2009\SolidWorks DWGEditor 2009.ini with the following
content:

[Package]

WIPackage=DWGeditor.msi

Description=Package for SolidWorks DWGEditor 2009

0S=5.WS

Addcommand=INSTALLDIR="C:\Program Files\DWGEditor" DWGASSOC=1 LICENCETYPE=2
SERVERLIST=25734@ComputerName

Dependencies=SolidWorks 2009

Note that the Addcommand line is only one line — it has been split onto two due to its length. Also you will need to change
25734@ ComputerName to your own port number and computer name that you specified in step 2-11, page 18.

e In RM Management Console:
For CC3:
o Update the package list
For CC4:
o Choose File > Import > Package
Choose Community Connect 3 Package
Click Browse
Select the SolidWorks DWGEditor 2009.ini you just created
Click Open
Click OK.

© O O 0 ©
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On any station:
¢ Insert the DVD
¢ Open a command prompt by going to Start>Run>cmd (or in Vista Start>Start Search). Run the following
commands:
o <drive letter>:
o cd eDrawings
o msiexec /a eDrawings.msi
e This will launch a wizard. Click Next
* Enter a path (eg., Q:\Applications\SolidWorks eDrawings 2009) and click Install
* The data will then be copied to the folder (this will take a few mins)
¢ When it has finished, disable performance logging, tell it not to launch and close the wizard
e For CC3:
Edit the file Q:\Applications\SolidWorks eDrawings 2009\SolidWorks eDrawings 2009.ini and add to the end of the
file the lines:

Addcommand=INSTALLDIR="C:\Program Files\eDrawings" ADDLOCAL=ALL
LOGPERFORMANCE=0 SNLSERVER=25734@ComputerName
Dependencies=SolidWorks 2009

For CC4:
Create the file Q:\Applications\SolidWorks eDrawings 2009\SolidWorks eDrawings 2009.ini with the following
content:

[Package]

WIPackage=eDrawings.msi

Description=Package for SolidWorks eDrawings 2009

0S=5.Ws

Addcommand=INSTALLDIR="C:\Program Files\eDrawings" ADDLOCAL=ALL
LOGPERFORMANCE=0 SNLSERVER=25734@ComputerName
Dependencies=SolidWorks 2009

Note that the Addcommand line is only one line — it has been split onto two due to its length. Also you will need to change
25734@ ComputerName to your own port number and computer name that you specified in step 2-11, page 18.

¢ In RM Management Console:
For CC3:
o Update the package list
For CC4:
o Choose File > Import > Package
o Choose Community Connect 3 Package
Click Browse
Select the SolidWorks eDrawings 2009.ini you just created
Click Open

0
0
0
o Click OK.
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Creating the SolidWorks Simulation Packages

SolidWorks Simulation Premium

On a station you can restore:
* Insert the DVD
e Open a command prompt by going to Start>Run>cmd (or in Vista Start>Start Search). Run the following
commands:
0 <drive letter>:
o cd cwwNCOSMOSM\
o msiexec /a COSMOSM_English.msi
e This will launch a wizard. Click Next
e Tell the wizard you will set up license configuration later. Click Next
« Enter a path (eg., OQ:\Applications\SolidWorks Simulation Premium 2009) and click Install
* The data will then be copied to the folder (this will take a few mins)
* When it has finished, close the wizard
e For CC3:
Edit the file Q:\Applications\SolidWorks Simulation Premium 2009\SolidWorks Simulation Premium 2009.ini and
add to the end of the file the lines:

Addcommand=INSTALLDIR="C:\Program Files\COSMOS" SOLIDWORKSDIR="C:\Program
Files\SolidWorks" SERVERLIST=25734QComputerName
Dependencies=SolidWorks 2009

For CC4:
Create the file Q:\Applications\SolidWorks Simulation Premium 2009\SolidWorks Simulation Premium 2009.ini
with the following content:

[Package]

WIPackage=COSMOSM English.msi

Description=Package for SolidWorks Simulation Premium 2009

0S=5.WS

Addcommand=INSTALLDIR="C:\Program Files\COSMOS" SOLIDWORKSDIR="C:\Program
Files\SolidWorks" SERVERLIST=25734@QComputerName

Dependencies=SolidWorks 2009

Note that the Addcommand line is only one line — it has been split onto two due to its length. Also you will need to change
25734@ ComputerName to your own port number and computer name that you specified in step 2-11, page 18.

* In RM Management Console:
For CC3:
o Update the package list
For CC4:
o Choose File > Import > Package
Choose Community Connect 3 Package
Click Browse
Select the SolidWorks Simulation Premium 2009.ini you just created
Click Open
Click OK.

© O © O O
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SolidWorks Flow Simulation

On any machine:
¢ Insert the DVD
¢ Open a command prompt by going to Start>Run>cmd (or in Vista Start>Start Search). Run the following
commands:
o <drive letter>:
o cd cwwNCOSMOSFloWorks\
o msiexec /a i386_SolidWorksFlow_English.msi
e This will launch a wizard. Click Next
¢ Ignore the serial number prompt and click Next
e Tell the wizard you will set up license configuration later. Click Next
* Enter a path (eg., Q:\Applications\SolidWorks Flow Simulation 2009) and click Install
¢ The data will then be copied to the folder (this will take a few mins)
e When it has finished, close the wizard
e For CC3:
Edit the file Q:\Applications\SolidWorks Flow Simulation 2009\SolidWorks Flow Simulation 2009.ini and add to
the end of the file the lines:

Addcommand=INSTALLDIR="C:\Program Files\COSMOS" SOLIDWORKSDIR="C:\Program
Files\SolidWorks" SERVERLIST=25734QComputerName
Dependencies=SolidWorks 2009, SolidWorks Simulation Premium 2009

For CC4:
Create the file Q:\Applications\SolidWorks Flow Simulation 2009\SolidWorks Flow Simulation 2009.ini with the
following content:

[Package]

WIPackage=SolidWorksFlow English.msi

Description=Package for SolidWorks Flow Simulation 2009

0S=5.WS

Addcommand=INSTALLDIR="C:\Program Files\COSMOS" SOLIDWORKSDIR="C:\Program
Files\SolidWorks" SERVERLIST=25734QComputerName

Dependencies=SolidWorks 2009, SolidWorks Simulation Premium 2009

Note that the Addcommand line is only one line — it has been split onto two due to its length. Also you will need to change
25734@ ComputerName to your own port number and computer name that you specified in step 2-11, page 18.

e In RM Management Console:

For CC3:
o Update the package list

For CC4:
o Choose File > Import > Package
o Choose Community Connect 3 Package
o Click Browse
o Select the SolidWorks Flow Simulation 2009.ini you just created
o Click Open
o Click OK.
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SolidWorks Motion

On any machine:
* Insert the DVD
¢ Open a command prompt by going to Start>Run>cmd (or in Vista Start>Start Search). Run the following
commands:
0 <drive letter>:
o cd cwwNCOSMOSMotion\
o msiexec /a SolidWorks Motion.msi
e This will launch a wizard. Click Next
* Insert the extended serial number you noted earlier
 Enter a path (eg., O:\Applications\SolidWorks Motion 2009) and click Install
¢ The data will then be copied to the folder (this will take a few mins)
e When it has finished, close the wizard
e For CC3:
Edit the file Q:\Applications\SolidWorks Motion 2009\SolidWorks Motion 2009.ini and add to the end of the file the
lines:

Addcommand=INSTALLDIR="C:\Program Files\COSMOS" SOLIDWORKSDIR="C:\Program
Files\SolidWorks" SERVERLIST=25734QComputerName
Dependencies=SolidWorks 2009, SolidWorks Simulation Premium 2009

For CC4:
Create the file Q:\Applications\SolidWorks Motion 2009\SolidWorks Motion 2009.ini with the following content:

[Package]

WIPackage=SolidWorks Motion.msi

Description=Package for SolidWorks Motion 2009

0S=5.WS

Addcommand=INSTALLDIR="C:\Program Files\COSMOS" SOLIDWORKSDIR="C:\Program
Files\Solidworks" SERVERLIST=25734QComputerName

Dependencies=SolidWorks 2009, SolidWorks Simulation Premium 2009

Note that the Addcommand line is only one line — it has been split onto two due to its length. Also you will need to change
25734@ ComputerName to your own port number and computer name that you specified in step 2-11, page 18.

* In RM Management Console:
For CC3:
o Update the package list
For CC4:
o Choose File > Import > Package
Choose Community Connect 3 Package
Click Browse
Select the SolidWorks Motion 2009.ini you just created
Click Open
Click OK.
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SolidWorks Simulation

On any machine:
¢ Insert the DVD
¢ Open a command prompt by going to Start>Run>cmd (or in Vista Start>Start Search). Run the following
commands:
o <drive letter>:
o cd cwwNCOSMOSWorks\
o msiexec /a SolidWorks Simulation.msi
e This will launch a wizard. Click Next
¢ Insert the extended serial number you noted earlier
* Enter a path (eg., Q:\Applications\SolidWorks Simulation) and click Install
¢ The data will then be copied to the folder (this will take a few mins)
e When it has finished, close the wizard
e For CC3:
Edit the file Q:\Applications\SolidWorks Simulation 2009\SolidWorks Simulation 2009.ini and add to the end of
the file the lines:

Addcommand=INSTALLDIR="C:\Program Files\COSMOS" SOLIDWORKSDIR="C:\Program
Files\Solidworks" SERVERLIST=25734QComputerName
Dependencies=SolidWorks 2009, SolidWorks Simulation Premium 2009

For CC4:
Create the file Q:\Applications\SolidWorks Simulation 2009\SolidWorks Simulation 2009.ini with the following
content:

[Package]

WIPackage=SolidWorks Simulation.msi

Description=Package for SolidWorks Simulation 2009

0S=5.WS

Addcommand=INSTALLDIR="C:\Program Files\COSMOS" SOLIDWORKSDIR="C:\Program
Files\SolidWorks" SERVERLIST=25734QComputerName

Dependencies=SolidWorks 2009, SolidWorks Simulation Premium 2009

Note that the Addcommand line is only one line — it has been split onto two due to its length. Also you will need to change
25734@ ComputerName to your own port number and computer name that you specified in step 2-11, page 18.

e In RM Management Console:

For CC3:
o Update the package list

For CC4:
o Choose File > Import > Package
o Choose Community Connect 3 Package
o Click Browse
o Select the SolidWorks Simulation 2009.ini you just created
o Click Open
o Click OK.
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FURTHER NOTES AND TROUBLESHOOTING

1. Serial Number Errors
. Network Licenses with Firewalls

Dongle Installation Problems
Administrative Images
. Services/Processes still running at install time

I NN

1. Serial Number Errors
If you get a prompt box saying your serial number is not a SolidWorks serial number, ignore this message
and click CANCEL

34 SolidWorks 2009 SP2.1 Installation Manager

SolidWorks Installation Manager

‘Your serial number could not be validated. It may have been entered in the wrong Field (Solidwiorks), it may be an invalid serial number, there may be
a server error, of your mainkenance may have expired. If wou received the serial number recently, please try again later.

—

T ST IO T T

Then click Next

1" SolidWorks 2009 SP2.1 Installation Manager

pSuIidW(Jrks

0 Installation Messages

The Instaliation Manager could not validate your serial number to automatically
determine the products to which you are entitled. You must select products
manuslly.

Downloads have been disabled because your serial number could not be
wvalidated.

Click Next to continue.

J
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SolidWorks

Record Your New Serial Number

Your serial number has been updated for enhanced security.

SolidWorks: [9700 0071 5178 5959 QGIN X7+ | <

2. Network Licenses with Firewalls
If your computer uses a firewall, you will need to open two ports on the server to allow clients to connect
and obtain licenses. The default ports are 25734 and 25735 (see page 18). Set up the ports as follows:

* Firewall software. With Internet firewall software, you must add two ports to your firewall exceptions
list. See your System Administrator.

* Windows Firewall. If you use Windows Firewall, you must modify ports on the license server to allow
clients to connect and obtain licenses.

To modify ports in Windows Firewall:
1. Go to Start>Run and type in firewall.cpl.

2. If you don’t see the Exceptions tab you may need to click on Allow a program through windows
firewall or change settings, depending on the version of Windows in use.

3. Click on the Exceptions tab, then click on Add port
4. Type a name, (for example, SNL-inport) and your port number (for example, 25734)
5. Select the TCP protocol and click OK.

6. Repeat the process for the second port and then close the Windows Firewall window.

~N
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3. Dongle Installation Problems

USB dongle - when to insert and device drivers.

When you insert the USB dongle for the first time, Windows will detect the device and may try to install
drivers for the device. You do not want to install drivers for the USB dongle and should choose not to, or
stop Windows from continuing, as they are installed by SolidWorks Installation Manger part way through
the installation. It is for this reason that we recommend not plugging in the USB dongle until the
SolidWorks Installation Manager prompts you for it.

In this example (Windows Vista) you should click on Ask me again later, you will not be asked again later
unless there is a problem with the installation.

+"| Found New Hardware lihj

Windows needs to install driver software for your HASP HL
321

¥ Locate and install driver software (recommended)
Windows will guide you through the process of installing driver software
for your device,

+ Ask me again later
Windows will ask again the next time you plug in your device or log on.

&) Don't show this message again for this device
Your device will not function until you install driver software,

Cancel

Problems reading dongle

Some users have reported that a message is given during the process of running through the SolidWorks
Network License Wizard at the point of reading the SNL file, indicating that the dongle is not recognized or
the dongle ID cannot be read (or similar).

SolidNetWork License File Wizard | X . . —
SolidNetWork License Administrator E3

8 The license information file did not contain the correct dongle ID(s).

z | ;
s ' Could not read the dongle ID number

Please remove then reinsert the dongle, making sure it
Instead found: is firmly connected on this computer then press Retry.

FLEXID=9-4ADEA601
Cancel l

SolidMetWork License Administrator @

! Could not read the dongle ID number.
Please remove then reinsert the dongle, making sure it
is firmly connected on this computer then press Retry.

MOTE: if this is a remote connection, log off and reconnect
to the server consele session in erder to read the dongle ID
(ex: for Microsoft Remote Desktop use 'mstsc.exe /conscle’)

This problem most frequently occurs where a remote desktop application such as Remote Desktop
Connection, VNC, Symantec pcAnywhere, is being used. If this is the case, installing DIRECTLY on the
server should solve the problem.

The problem can also occur if the USB dongle driver software has not installed correctly. If this is the case,
you should click OK to complete the SolidNetwork License Wizard, then un-install and re-install the dongle
driver software manually as follows:

J
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To remove the dongle driver software:

Either:

Use Device Manager and under USB devices remove items with the name HASP, FLEX or Aladdin.
Or:

Open a DOS command prompt and type:

cd C\Program Files\SolidWorks SolidNetWork License Manager\setup\i386

Press [ENTER] to change the prompt into that directory, then type haspdinst -r

and press [ENTER]. This will remove the driver.

To re-install the dongle driver software:

Open a DOS command prompt and type:

cd C:\Program Files\SolidWorks SolidNetWork License Manager\setup\i386
Press [ENTER] to change the prompt into that directory, then type haspdinst —i

N.B. In some cases the previous command will result in an ‘INOPERABLE BATCH FILE’ error, in which
case you should instead type: hinstall -i and press [ENTER].

When the operation completes successfully the LED on the USB dongle will light.

In a few cases it has been found that Window’s DEP (Data Execution Settings) can be another reason
for communication problems between the SolidWorks Network License software and the dongle. The
settings should be configured as follows:

Choose Start > Control Panel > System > Advanced > Performance > Settings > Data Execution
Prevention (DEP), select the second radio button and add sw_d.exe, swimwiz.exe and Imgrd.exe to the
exception list.

4. Administrative Images

SolidWorks Installation Manager S

®5  Error 1328.Error applying patch to file C:AConfig MsiPTCOSE tmp. &t
\ 0 ! has probably been updated by other means, and can no lenger be
~ rnodified by this patch, For more information centact yeur patch
wendar,

| Abort | | Betry | | Ignore

You may experience this error when creating admin images. It is related to Microsoft components that are
installed with SolidWorks. You should choose to Ignore the error, which usually occurs because you have a
more recent version of a software component than the installer is trying to use.

-

J
7 Troubleshooting ‘ @




‘, /775 Installation )
’ SolidWorks Guide )

~N

5. Services/Processes Still Running at Install

SolidWarks 2008 SP02.1 X =
Sotiaworks 2008 5707 | S & [ 51cccse: Runring S
| _The foll_owi.ng applications should be closed before continuing the THeinstalahon Marener has detecd other
installation: 1] % : :
. Solidworks processes running, which may prevent
swEOEngine successful installation, Close these applications and
| processes before continuing using Retry”, or
"Cancel” to stop the installation.
SolidWorks Task Scheduler Engine {swboengine.ex
@ Autom_aticalh' close applications and attempt to restart them after [ Retry | | Cancel |
setup is complete. .

Do not close applications. (& Reboat will be required )

SolidWorks SolidMetWork License Manager @
ok | [ Cancel | N
lige B The setup must update files or services that cannot be
"&Y  updated while the system is running. fyou choose to
continue, a reboot will be required to complete the
Warning : (]| EEn:
The Installation Manager has detected other SolidWarks processes stil | oK | [ Cancel
! running. To ensure successful installation, these processes should be

stopped. If you do not halt them, a reboot may be required after
installation,

In the event of receiving an error message similar those above, you may need to stop the
swBOEngine process manually. To do this press CTRL + ALT + DELETE and then click on Task

Manager or Start Task Manager. _
‘& Windows Task Manager _ E@Iﬁ

Eile Opticns  View Help
Applications | Processes |Servir.es | Performance | Metwarking | Users |
Select swBOEngine.exe in the Processes list = -
Image Mame User Mame CPU  Memory {... Descripton  *
igfxpers.exe TechSo... ] 930 K persisten...
Click on the End Process button. igfxsrve.exe TechSo... 00 1,324K  ighsrvc ...
igfxtray.exe TechSo... lu} 1,012K  igfxTray ...
lightscreen.exe  TechSo... ] 22,816 K lightscreen
At the next message box’ click the LightscreenPo.., TechSo... 00 2,368 K Lightscre...
E d P b MSASCUI. exe TechSa... [aln] 5,196 K Windows ...
nd Process button RIHDVCplexe  TechSo... 00 2,768 K HD Audio ...
sidebar.exe TechSo... 00 11,884 K Windows ..,
sldim. exe TechSo... [al] 15,352 K sldIM =
sldIMSchedule... TechSo... ala] 1,500 K sldIM
i swBOEngine,...  TechSo... 00 3,996 K swBOEngine :
taskeng.exe TechSo... i} 2,896 K Task Sche...
taskmagr.exe TechSo... 01 1,956 K Windows ...
winlogon. exe [lu} 1,628 K
wmpnscfg.exe  TechSo... [iu} 1,264K  Windows ...
| |7 Show processes from all users End Process
Processes: 55 CPU Usage: 2% Physical Memory: 36%

Windows Task Manager &J

Do you want to end this process?

If an open program is associated with this process, it will close
and you will lose any unsaved data. If you end a system
process, it might result in an unstable systermn. Are you sure
you want to continue?

End process ]| Cancel

Troubleshooting
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You may also need to stop any SolidWorks related
services, click on the Services tab in task manager.
To stop a running service, select the service in the
list, then right click on it, when the menu pops up
click on Stop Service. The following services may
be running and causing problems with the
installation:

SolidWorks Licensing Service
Remote Solver for COSMOSFloWorks 2008

7S Installation
SolidWorks Guide
[ %8 Windows Task Manager |.E|EI&J

File Options | View | Help

Applications | Processes | Services | Performance i MNetworking IUsers |

Mame FID Description
# Remote Solver for COSMOSFlo\Works 2008 2320 Remote Solve
RemoteAccess Routing and F
seclogon 1076  Secondary Lo
SstpSvc 1244 Secure Socke
Samss 604 Security Acco
WSESVE 1040  Security Cent
LanmanServer 1075 Server
ShelHWDetection 1075 Shell Hardwar| =
SLUIMotify SL UI Motifica
SCardsvr Smart Card
SCPolicySve Smart Card R
SNMPTRAP SNMP Trap
slave 1208 Software Lice
#Soli SolidWorks Lic _
. S = =
¢ Services...

Processes: 61

CPU Usage: 0%

Physical Mermory: 53%
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