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INTRODUCTION

This booklet has been written to assist users when installing SolidWorks Education Edition 2009-10.
The installation should be straightforward on most systems.  However sometimes problems can arise, either
through system issues, licensing issues, network issues, user error, etc.  These problems may vary
depending on whether it is a new installation or an upgrade.  In our experience it is much simpler and
quicker to avoid the problems in the first place, rather than to try to sort them out if things have gone
wrong.  Hence, the reason for this booklet.

TechSoft strongly advise users to read through these notes, and to follow them carefully when
installing the software.  This should minimise the chances of any problems occurring.

Additional information is available on the SolidWorks website, www.solidworks.com.  Some of the more
popular links can be found at www.techsoft.co.uk/swresourcelinks.htm (or go to www.techsoft.co.uk,
then choose SOFTWARE > SolidWorks > Customer Support).

The following names of products have changed from SolidWorks 2008 to SolidWorks 2009:

NEW FEATURES
Details of the new features available in SolidWorks 2009 can be found at http://www.solidworkslaunch.com

SolidWorks 2008 SolidWorks 2009

SolidWorks 3D MCAD Software SolidWorks® Standard

SolidWorks Office Professional SolidWorks® Professional

SolidWorks Office Premium SolidWorks® Premium

PDMWorks® Enterprise SolidWorks® Enterprise PDM

PDMWorks Workgroup SolidWorks® Workgroup PDM 

COSMOS SolidWorks® Simulation

COSMOS FloXpress SolidWorks® FloXpress

COSMOSFloWorks SolidWorks® Flow Simulation

COSMOSMotion SolidWorks® Motion 

COSMOSWorks Designer SolidWorks® Simulation

COSMOSWorks Professional SolidWorks® Simulation Professional

COSMOSWorks Advanced Professional SolidWorks® Simulation Premium

COSMOSM SolidWorks® Simulation Premium

COSMOSXpress SolidWorks® SimulationXpress

DWGseries SolidWorks® DWGseries

eDrawings SolidWorks® eDrawings®

eDrawings Professional SolidWorks® eDrawings® Professional
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PREPARATION

1. Verify that your system meets the criteria specified at www.solidworks.com/System_Requirements.
In particular note that the minimum RAM requirement is 1Gb.  Although the software can be installed
and run on a computer with less RAM than this, it is likely to run too slowly to be practical.

2. Locate your Serial Number (S/N). The number typically begins with 9710 (Network) or 9700/9701
(Stand Alone). 

For New Users:
The serial number is located on the front of the box on a sticker and/or on your invoice/delivery note.

For Existing Users:
The serial number can be found from within SolidWorks by choosing Help > About SolidWorks.  It can
also be located on the front of the original box on a sticker, and/or on your original invoice/delivery
note. 

3. Existing Users Only:
Back up all SolidWorks files (parts, assemblies, and drawings, document templates, sheet formats,
library features, and form tools) before upgrading to SolidWorks 2009.  Files you open and save in
SolidWorks 2009 cannot be opened in earlier versions. 

4. Existing Users Only:
Choose whether to Upgrade or to Un-install, Clean-up and Re-install
Whilst upgrading an existing installation is the most straightforward to implement, please be aware that
many files from the old version will still reside on the computer after installation.  

In order to minimise disk space, you should consider uninstalling your older Education Edition,
cleaning up, then using a new installation of SolidWorks 2009-10 Education Edition.  If you do choose
this approach you will need to note the following:

a. Before uninstalling any stand-alone copy of SolidWorks, you should transfer your license by
choosing Help > Transfer Licenses... from within SolidWorks.

b. After uninstalling the main SolidWorks program, you should also uninstall all COSMOS
products, along with older versions of eDrawings, DWGEditor, etc.

c. For a complete “clean-up”, the old registry keys will need to be deleted.  Full details of how to do
this can be found at http://www.solidworks.com/sw/support/Tech_Tips/TT_CleanUpdate.html. If
the old registry keys are left in place, SolidWorks will default to the old folders for File Locations
and Default Templates (this is so that users do not think that they have “lost” their old work).
These folder locations can subsequently be changed from within SolidWorks using Tools  >
Options, but unless the user is made aware this, some confusion can result where old files are in
the SolidWorks 2008 folder and new files are in the SolidWorks 2009 folder. 

5. Administrative rights are necessary on the local system in order to perform SolidWorks installation or
upgrades. 

6. Most anti-virus applications are compatible with SolidWorks software and will not block its
installation.  However, a few are not, and these will need to be disabled before SolidWorks is installed.
For a list of anti-virus products that have been tested for compatibility with SolidWorks installation and
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usage, please see http://www.solidworks.com/sw/support/AntiVirus_SW.html 

7. Installation of SolidWorks can be done whether the computer is connected to the Internet or not.
However, many of the processes are automated if a live internet connection is available, so this is
strongly recommended.  

8. SolidWorks includes a library of standard hole types and hardware.  By default the library will be
installed into C:\SolidWorks Data.  If you are doing a network installation you should consider placing
the library on a network share so that further upgrades, installations or additions to the library only
need to be done once on the shared folder.  This can also be done when setting options for an
administrative image.

Preparation4

Installation
Guide



STAND ALONE INSTALLATION

Installation of SolidWorks can be done whether the computer is connected to the Internet or not.  However,
many of the processes are automated if a live internet connection is available, so this is strongly
recommended.

1. If you are an existing user, start up your current software and, after noting down your serial number
(see page 3, note 2), choose Help > Transfer License before upgrading or uninstalling (see page 3, note
4).  This ensures that the nmber of activations is not exceeded.

2. Insert the SolidWorks 2009 DVD into your DVD drive.  If the software does not start up automatically,
choose My Computer and click on the appropriate drive.

3. A Welcome Screen will appear.  

For a new installation enter your serial number (just 16 digits, ignore the last two boxes); for existing
users the serial number may already be there.  Click Next.

If you have only entered a 16 digit serial number, the last 8 digits will be automatically generated and
then presented to you.  You should record the full 24 digit serial number then click Next.

4. If a later version of the software has been detected over the internet, you will be given the opportunity
to Download and install a new version.  As SolidWorks is such a large piece of software, you are
STRONGLY ADVISED NOT TO DOWNLOAD, as download times for the full program can take
many hours. Choose Continue installing SolidWorks 200     9 SP2.1 (the default) then click Next.

LEAVE BLANK
IF NOT KNOWN

Note:

If you receive an error
message about your serial
number, refer to Serial
Number Errors on page 42.
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5. The SolidWorks Setup Wizard will guide you through the    installation.  Choose Individual for the
Installation Type and click Next.    If applicable, choose  your ‘Upgrade Option’ (see page 3, note 4)
and click Next to continue.

6. Accept the default settings on the following screen (if you do not have a live internet connection, you
must ensure that SolidWorks Premium is first selected then add COSMOSM), click Next.

When the prompt asks you where you would like to put Hole Wizard and Toolbox Files, consider the
options available, further information is available by clicking on help.  New users can accept the
default C:\SolidWorks Data or choose another location if preferred.  If you are an existing customer
and would like to upgrade your current folder that contains the standard library files (SolidWorks
Toolbox, etc), click Browse and find the folder with your existing standard library files then click OK. 
Existing customers can also choose to install new Hole Wizard and Toolbox Files if preferred by
Browsing to a new or empty folder.

After choosing your folder, click Next. 
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7. Ready to Install, click Install Now
There are a number of error messages that may appear during installation, depending on your choices
and currently installed software.  Please refer to the Troubleshooting section at the end of this book if
further information is needed.

8. Installation is Complete. Click Finish. 

N.B. Depending on your computer configuration you may or may not need to restart your computer.
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9. When you start SolidWorks Education Edition for the first time, SolidWorks Product Activation prompt
will show.  Click Next to continue.  

10. To activate your SolidWorks product you must request a license key from SolidWorks.  This can be
done automatically by choosing Automatically over the Internet (recommended), or if the computer on
which you are installing the software is not connected to the Internet, it can be done manually via e-
mail. 
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11. Fill in the appropriate fields then click Next. 

12. You have now registered your SolidWorks Education Edition. Click Finish. 
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NETWORK INSTALLATION

The general procedure is to first install the SolidWorks Network License software (SolidNetWork License
Manager) and the dongle on the license server, then to install SolidWorks on each of the client computers.

LICENSE SERVER 

� Dongle

� SolidWorks Network
License Software

LICENSE CLIENTS 

� Install SolidWorks Software
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Step 1 - Obtaining a License File

1. Go to www.solidworks.com and then click login.  

2. Once you are in the page headed “Logins for SolidWorks Communities”, click SolidWorks Customer
Portal.  This will direct you to the sign-in page for the customer portal. 

3. If you already have an account, enter your email address and password then proceed to step 7.  To
create a new account, once you are in the sign-in page, on the right side of the page, click on Click here
to create a Sign-In account. 

4. Enter your serial number in the box and click Next at the bottom of the page. 
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5. After you have completed filling out your Serial Number, you will then be asked to verify your
information.  After you have verified, click Yes, this information is accurate.

6. Next, type in your email address in the box and click Next. Fill in the appropriate fields asked in the
next step.  (N.B.  You will not be able to move forward if you have not completed the required fields
which are indicated with a red asterisk.)  
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7. You have successfully signed in to the Customer Portal.  In order for Full Access to the portal, you
must Register your Products.  Under My Support, click Register My Products.

8. After you click Register My Product, you will have to enter your SolidWorks Serial Number in the box.
(The number typically begins with 9710 and is located on the front of the box on a sticker and/or your
invoice/delivery note. If you cannot find, or you have misplaced your number, please contact TechSoft.)
Then click Next.  
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 9. Once you have entered your serial number, you will then be asked what version you have. Click the
icon next to the box to find your version and then click Next. 

10. The SolidWorks Network License File (.txt) will be emailed to you. You should receive this file in a
few minutes. (Note: SAVE THE NETWORK LICENSE FILE TO YOUR HARD DRIVE. You will
need this in Step 2.)  Click Next.
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Step 2 - Installing the SolidWorks Network License Software

      You must assign one computer (usually a server) to be your SolidWorks License Server.  On this you must
install the SolidWorks Network License software (SolidNetWork License Manager) as follows:

N.B.  Always install the SolidWorks Network License Software and dongle driver software DIRECTLY on
the server.  Installing it using a remote desktop application such as Remote Desktop Connection, VNC,
Symantec pcAnywhere, has been found to cause problems in most cases.

1. If you have a PARALLEL SolidWorks dongle, fit it now.  If you have a USB SolidWorks dongle, and
are installing SolidWorks for the first time, do not fit the dongle until instructed to do so. 

2. Insert the SolidWorks 2009 DVD into your DVD drive.  If the software does not start up automatically,
choose My Computer and click on the appropriate drive.

3. A Welcome Screen will appear.  For a new installation enter your serial number (just 16 digits, ignore
the last two boxes); for existing users the serial number should already be there.  Click Next.

 If you have only entered a 16 digit serial number, the last 8 digits will be automatically generated and
then presented to you.  You should record the full 24 digit serial number then click Next.

Note:

If you receive an error
message about your serial
number, refer to Serial
Number Errors on page 42.

LEAVE BLANK
IF NOT KNOWN

Note:

• All previous License Managers must be removed from your computer before beginning the
installation of the new License Manager (ie., 2008 must be removed before installing 2009).

• The License Manager must be installed on the machine that will be used to distribute
SolidWorks licenses on your network.

• Your dongle (hardware lock) must be inserted on the machine where you will install your
License Manager and not any other machine.

• The License Manager for 2009 will license both SolidWorks and SimulationXpress (formerly
COSMOS) products. In addition it will license SolidWorks 2008 based EDU products. Older
versions of SimulationXpress will require the older SimulationXpress only License Manager.

Network License 15

Installation
Guide



4. If a later version of the software has been detected over the internet, you will also be given the
opportunity to Download and install a new version.  As SolidWorks is such a large piece of software,
you are STRONGLY ADVISED NOT TO DOWNLOAD, as download times for the full program can
take many hours. Choose Continue installing SolidWorks 2009 SP2.1 (the default), then click Next.

5. You will be asked to choose what you would like to install.  Choose Administrative Image and Server
Products, then ONLY have Install SolidNetWork License Server ticked.  Click Next.

6. You are now ready to install the SolidNetWork License Manager,  Click Next.
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7. You will be asked where you want the files to be installed.  After you choose, click Next.

8. You will next be asked what language you want as your default. After you choose your language, click
Next. 

9. Now you are ready to begin the installation. Click Install to proceed. 
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10. To continue the installation, DO NOT change the location where The wizard will help you create or
edit the FLEXlm license file. Keep the server type at Single, and then click Next. 

11. In this step of the installation, you will be given your server information.  PLEASE NOTE the
Computer Name and Port Number. (You will need the Computer Name and Port Number in Step 3.)
Once you have written down your Computer Name and Port Number, click Next.  

Note: 
The firewall option refers to
a software firewall such as
‘Windows Firewall’.  It is
highly likely that your
server will have some form
of software firewall enabled.
Please tick this option and
see the notes on page 43
about Network Licenses
with Firewalls.
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12.  You will now have to insert your SolidWorks Network License File that you obtained during Step 1.
(You were given a Network License File (.txt) during Step 1.  This file was placed on your hard drive.)
Click Read to insert your Network License File.  

13. Click Browse and locate the Network License File that you have copied to your hard drive. Once you
have located your Network License File, click OK. 
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14. Your Network License information will show up on the screen.  Once you have looked over your
information, click Finish. 

15. You are now finished installing the SolidWorks SolidNetWork License Manager.  Click Finish. 
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16. Click Finish to conclude the installation of the SolidNetWork License Manager.  
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Step 3 - Installing the SolidWorks Software on each Client Computer

There are now two ways to proceed.  You can either simply install SolidWorks on each computer from the
DVD, or you can create a one-step installer (administrative image) on the server and allow each client
computer to use this to install from.  

Method 1 - Install from DVD
This must be done on each computer that you wish to run SolidWorks on.

1. Insert the SolidWorks 2009 DVD into your DVD drive.  If the software does not start up automatically,
choose My Computer and click on the appropriate drive.

2. A Welcome Screen will appear.  

For a new installation enter your serial number (just 16 digits, ignore the last two boxes); for existing
users the serial number may already be there.  Click Next.

If you have only entered a 16 digit serial number, the last 8 digits will be automatically generated and
then presented to you.  You should record the full 24 digit serial number then click Next.

3. If a later version of the software has been detected over the internet, you will be given the opportunity
to Download and install a new version.  As SolidWorks is such a large piece of software, you are
STRONGLY ADVISED NOT TO DOWNLOAD, as download times for the full program can take
many hours. Choose Continue installing SolidWorks 200     9 SP2.1 (the default) then click Next.

LEAVE BLANK
IF NOT KNOWN

Note:

If you receive an error
message about your serial
number, refer to Serial
Number Errors on page 42.
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4. The SolidWorks Setup Wizard will guide you through the    installation.  Choose Individual for the
Installation Type and click Next.    If applicable, choose  your ‘Upgrade Option’ (see page 3, note 4)
and click Next to continue.

5. Accept the default settings on the following screen (if you do not have a live internet connection, you
must ensure that SolidWorks Premium is first selected then add COSMOSM), click Next.
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6a. If you are presented with the following screen (if the computer you have installed SolidWorks on is not
the license server).  Click Add. 

b. Enter your license server and the port number that you specified in step 2-9, page 18. The default port
is 25734.  Enter it as portNumber@computerName.  Then click OK. 

c. You should now see your license server listed in License administrator.  Click OK. 

NOTE:

If you are installing as
an upgrade to an
existing installation of
SolidWorks, it is
possible that the server
name will already be
included in the dialog
box
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7. When the prompt asks you where you would like to put Hole Wizard and Toolbox Files, consider the
options available, further information is available by clicking on help.  New users can accept the
default C:\SolidWorks Data or choose another location if preferred.  If you are an existing customer
and would like to upgrade your current folder that contains the standard library files (SolidWorks
Toolbox, etc), click Browse and find the folder with your existing standard library files then click OK. 
Existing customers can also choose to install new Hole Wizard and Toolbox Files if preferred by
Browsing to a new or empty folder.

After choosing your folder, click Next. 

6. Ready to Install, click Install Now.
There are a number of error messages that may appear during installation, depending on your choices
and currently installed software.  Please refer to the Troubleshooting section at the end of this book if
further information is needed.
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8. Installation is Complete. Click Finish. 

N.B. Depending upon your computer configuration you may or may not need to restart your computer.
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Method 2 - Create a One-Step Installer and install from this
You create a One-Step installer (administrative image) on the serv   er and then allow each client to use this to
install from.  (This method is ill-advised when using an RM CC3/4 network - see Notes for RM CC3 and
CC4 Network Users, page 32.)

1. On the server, insert the SolidWorks 2009 DVD into the DVD drive.  If the software does not start up
automatically, choose My Computer and double click on the appropriate drive.

2. A Welcome Screen will appear.  For a new installation enter your serial number (just 16 digits, ignore
the last two boxes); for existing users the serial number should already be there.  Click Next.

If you have only entered a 16 digit serial number, the last 8 digits will be automatically generated and
then presented to you.  You should record the full 24 digit serial number then click Next.

3. If a later version of the software has been detected over the internet, you will also be given the
opportunity to Download and install a new version.  As SolidWorks is such a large piece of software,
you are STRONGLY ADVISED NOT TO DOWNLOAD, as download times for the full program can
take many hours. Choose Continue installing SolidWorks 2009 SP2.1 (the default).  Click Next.

LEAVE BLANK
IF NOT KNOWN

Note:

If you receive an error
message about your serial
number, refer to Serial
Number Errors on page 42
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4. You will be asked to choose what you would like to install.  Choose Administrative Image and Server
installation, then ONLY have Create or update an Administrative Image ticked.

5. Choose a directory in which to install the administrative image (all client computers will need access to
this directory.)

6. After you have clicked Next, the SolidWorks Setup Wizard will guide you through the installation.
Accept Defaults on the following screen.  Click Next to continue installation.  
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7. Enter your license server and the port number that you specified in Step 2-11, page 18    .  The default
port is 25734. Enter it as portNumber@computerName. Then click OK. 

8. Over the next few screens you are required to set options for the Administrative Image.  Detailed
information is available for each screen by clicking on help.  Additionally you can edit these settings at
a later date if required (see point 12).
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9. When the prompt asks you where you would like to put Hole Wizard and Toolbox Files, consider the
options available, further information is available by clicking on help.  New users can accept the
default C:\SolidWorks Data or choose another location if preferred.  If you are an existing customer
and would like to upgrade your current folder that contains the standard library files (SolidWorks
Toolbox, etc), click Browse and find the folder with your existing standard library files then click OK. 
Existing customers can also choose to install new Hole Wizard and Toolbox Files if preferred by
Browsing to a new or empty folder.

After choosing your folder, click Next.  
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10. Ready to Install, click Install Now.

11. The image will now be created.

12. Once the image has been created, install SolidWorks on each client computer using the
“StartSWInstall.htm” file which you will find on the server within the directory you have just created.

N.B.  The options chosen on the previous screens including Client Install Options, SolidWorks settings,
Administrative Image Location, Image options etc. can be changed at any time using the Admin Option
Editor.  If you wish to do this, navigate to the folder where you made the image, find the html
application file named StartOptionEditor and double click it.  Click on ‘Start Admin Option Editor’. 
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Notes for RM CC3 and CC4 Network Users

IMPORTANT - ALL USERS

In order to run SolidWorks successfully on a RM CC3 or CC4 Network, it may be necessary to edit the RM
Software Restriction Settings.  It has been found that a problem occurs if the RM network permissions do
not let non-admin users copy a temporary licence file to c:\docs & settings\username\local settings\temp.  

To allow this file to be written do the following:

1. Open RM Management Console

2. For CC3: Open Configuration Settings folder and click on Software Restriction Settings.
For CC4: Choose Software > Software Restriction Policies.

3. Ensure that Path Rules is selected.
For CC3: Right click anywhere in the right-hand pane and select Add new path rule from the pop-up
menu.
For CC4: Click Add in the top right hand corner.

4. In the Path: box type the following:
%userprofile%\local settings\temp\solidworkslictemp.*

5. Ensure that Allow files in this path to be run is selected then enter a meaningful description.

6. Click OK to create the new rule then reboot the workstation to apply the new GPO.

7. SolidWorks should now run for all levels of users.

A special thank you to Mr Ian Munro, ICT Manager at Simon Balle School in Hertfordshire who discovered
this.

INSTALLATION

Network installation can be carried out as described in this user guide provided Method 1 - Installation
from DVD is used.

Unfortunately, due to the installation restrictions within an RM CC3 or CC4 Network, you are advised not
to use Method 2 - Create One Step Installer and install from this.

For those who wish to install the software using msi packages, we are very grateful to Mr Ian Liverton at
Beths Grammar School in Kent, who successfully installed SolidWorks 2008 Education Edition on their
RM CC3 Network, and, more recently, SolidWorks 2009 Education Edition on their RM CC4 Network.  He
has provided us with the following notes (some of which have been adapted after consultation with RM):
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Setting Up the Pre-requisite Microsoft Packages

SolidWorks 2009 requires other packages to be available.  These are the Microsoft Visual C++ 2005 Runtime, Microsoft .net
Framework version 3 or higher and Microsoft VSTA 2005 (Visual Studio Tools for Applications).  The first two will usually have
already been installed under CC4.  If all three are already installed on all your computers, then please proceed to Creating the
Main SolidWorks Package, page 34.

The following details how to obtain the Microsoft.net Framework 3.5 from RM.  It also details how to make the other two
Microsoft packages if you are unable to obtain them from RM.

Microsoft .net Framework 3.5
If you do not already have it, the Microsoft .net Framework 3.5 package can be obtained from RM.  Logon to the RM Support
website and load article DWN1460168 from the knowledge library.  Follow the instructions provided.

Microsoft Visual C++ 2005 Run time
To make a package for Microsoft Visual C++ 2005 Runtime:

• Insert the SolidWorks DVD
• Browse to DVD then PreReqs\VCRedist\vcredist_x86.exe
• Copy this file to any temporary folder, eg., C:\temp
• Create a new temporary folder, eg., C:\temp\VCRedist
• Open up the command prompt (Start > Run > cmd, or in Vista Start > Start Search) and type:

C:\temp\vredist_x86.exe /C
• Browse to the new folder you created , eg., C:\temp\VCRedist
• Open RM Application Wizard
• Select Manage a Windows Installer Package then click Next.
• Select Add an existing Windows Installer Package then click Next.
• Enter a name and description as follows:

Name: Microsoft Cplus plus 2005 Redistributable
Description: Microsoft Cplusplus redistributable (sourced from SolidWorks 2009 Install DVD)

• Under Package file (MSI) location, browse to C:\temp\VCRedist\vcredist.msi then click Next

Microsoft VSTA (Visual Studio Tools for Applications)
To make a package for Microsoft VSTA:

• Open RM Application Wizard
• Select Manage a Windows Installer Package then click Next.
• Select Add an existing Windows Installer Package then click Next.
• Enter a name and description as follows:

Name: Microsoft VSTA 2005 Redistributable
Description: Microsoft VSTA redistributable (sourced from SolidWorks 2009 Install DVD)

• Under Package file (MSI) location, browse to the SolidWorks DVD, then PreReqs\VSTA\vsta_aide.msi, then click
Next
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Installation
Guide

33



Creating the Main SolidWorks Package
On any machine:

• Insert the DVD
• Open a command prompt by going to Start>Run>cmd (or in Vista Start>Start Search).  Run the following

commands:
o <drive letter>:
o cd swwi\data\
o msiexec /a English_i386_SolidWorks.msi

• This will launch a wizard
• Click Next
• Select SolidWorks Office Premium, click Next
• Enter the serial number, click Next
• Enter a path (eg., Q:\Applications\SolidWorks 2009\) and click Install
• The data will then be copied to the folder (this will take about 30 mins)
• When this has finished, click Next to close the wizard and return to the command prompt. 

Run the following commands filling in your own details for the items in red (ie., serial number, port number and
computer name that you specified in step 2-11, page 18):

(N.B.  A fuller explanation of each command can be found by visiting www.techsoft.co.uk and clicking on the
following links: Software > SolidWorks >  Customer Support > SolidWorks Installation and Administration
Overview > Installation (Deploying Multiple Installations) > Command Prompt Deployment > SolidWorks feature
(ADDLOCAL parameter)  or > SolidWorks global (other parameters)

o Q:
o cd Applications\SolidWorks 2009
o SwCreateMST.exe English_i386_SolidWorks.Msi INSTALLDIR="C:\Program Files\SolidWorks"
SOLIDWORKSSERIALNUMBER="9710 XXXX XXXX XXXX"
ADDLOCAL=English,SampleFiles,Manuals,RealViewGraphicsdisplay,SolidWorks,FeatureWorks,InstantWebsite,Ph
otoWorksRender,ScanTo3D,SolidWorksAnimator,SolidWorksDesignChecker,SolidWorksRoutedsystems,SolidWorksT
oolbox,SolidWorksUtilities,TolAnalyst,CircuitWorks,DWGPartner,CoreSolidWorksTaskScheduler,ExampleFiles,Hel
pFiles,Intel_Modules_AgeiaX86 ENABLEPERFORMANCE=0 INSTALLWDS=0
SERVERLIST=25734@ComputerName OFFICEOPTION=3

Note you will need to change 25734@ComputerName to your own port number and computer name that
you specified in step 2-11, page 18.

• This will create an English_i386_SolidWorks.mst file in Q:\. Move this file to Q:\Applications\SolidWorks 2009\
• For CC3:

Edit the file Q:\Applications\SolidWorks 2009\SolidWorks 2009.ini and add to the end of the file the lines:

For CC4:
• In Q:\Applications\SolidWorks 2009\ create a file called SolidWorks 2009.ini with the following content:

(Microsoft VSTA 2005 Redistributable, Microsoft Cplus plus 2005 Redistributable
assumes the use of the packages created on previous pages - adapt as appropriate).

WITransform=English_i386_SolidWorks.mst
Dependencies=Microsoft VSTA 2005 Redistributable, Microsoft Cplus plus 2005
Redistributable

[Package]
WIPackage=English_i386_SolidWorks.msi
Description=Package for SolidWorks 2009 SP2.1
OS=5.WS
WITransform=English_i386_SolidWorks.mst
Dependencies=Microsoft VSTA 2005 Redistributable, Microsoft Cplus plus 2005
Redistributable
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• If this is a new install, in RM Management Console:
For CC3:

o Update the package list
o Open the Configuration Settings folder
o Go to Software Restrictions Settings
o Ensure that the Path Rules radio button is selected, then right-click anywhere in the right-hand pane and select 

Add New Path Rule from the pop-up menu

o In the Path box type: 

o Ensure that the Allow files in this path to be run radio button is checked, and enter a meaningful description
o Click OK to apply the rule

For CC4:
o Go to Software > Software Restriction Policies
o Ensure that the Path Rules radio button is selected.
o Click Add in the top right hand corner

o In the Path box type: 

o Ensure that the Allow files in this path to be run is selected in the drop down list, and enter a meaningful
description.
o Click OK to apply the rule

• For all installs, in RM Management Console:
For CC3:

o Update the package list
For CC4:

o Go to File > Import > Package
o Choose Community Connect 3 Package
o Click Browse
o Select the SolidWorks 2009.ini you just created 
o Click Open
o Click OK.  (Be patient- the package may take some time to import).

%userprofile%\local settings\temp\solidworkslictemp.*

%userprofile%\local settings\temp\solidworkslictemp.*
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Creating the DWGEditor and eDrawings Packages

DWGEditor
On any station:

• Insert the DVD
• Open a command prompt by going to Start>Run>cmd (or in Vista Start>Start Search).  Run the following

commands:
o <drive letter>:
o cd DWGeditor
o msiexec /a DWGeditor.msi

• This will launch a wizard.  Click Next
• Enter a path (eg., Q:\Applications\SolidWorks DWGEditor 2009) and click Install
• The data will then be copied to the folder (this will take a few mins)
• When it has finished, close the wizard
• For CC3:

Edit the file Q:\Applications\SolidWorks DWGEditor 2009\SolidWorks DWGEditor 2009.ini and add to the end of
the file the lines:

For CC4:
Create the file Q:\Applications\SolidWorks DWGEditor 2009\SolidWorks DWGEditor 2009.ini with the following
content:

Note that the Addcommand line is only one line – it has been split onto two due to its length. Also you will need to change
25734@ComputerName to your own port number and computer name that you specified in step 2-11, page 18.

• In RM Management Console:
For CC3:

o Update the package list
For CC4:

o Choose File > Import > Package
o Choose Community Connect 3 Package
o Click Browse
o Select the SolidWorks DWGEditor 2009.ini you just created 
o Click Open
o Click OK.

Addcommand=INSTALLDIR="C:\Program Files\DWGEditor" DWGASSOC=1 LICENCETYPE=2
SERVERLIST=25734@ComputerName
Dependencies=SolidWorks 2009

[Package]
WIPackage=DWGeditor.msi
Description=Package for SolidWorks DWGEditor 2009
OS=5.WS
Addcommand=INSTALLDIR="C:\Program Files\DWGEditor" DWGASSOC=1 LICENCETYPE=2
SERVERLIST=25734@ComputerName
Dependencies=SolidWorks 2009
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eDrawings
On any station:

• Insert the DVD
• Open a command prompt by going to Start>Run>cmd (or in Vista Start>Start Search).  Run the following

commands:
o <drive letter>:
o cd eDrawings
o msiexec /a eDrawings.msi

• This will launch a wizard.  Click Next
• Enter a path (eg., Q:\Applications\SolidWorks eDrawings 2009) and click Install
• The data will then be copied to the folder (this will take a few mins)
• When it has finished, disable performance logging, tell it not to launch and close the wizard
• For CC3:

Edit the file Q:\Applications\SolidWorks eDrawings 2009\SolidWorks eDrawings 2009.ini and add to the end of the
file the lines:

For CC4:
Create the file Q:\Applications\SolidWorks eDrawings 2009\SolidWorks eDrawings 2009.ini with the following
content:

Note that the Addcommand line is only one line – it has been split onto two due to its length. Also you will need to change
25734@ComputerName to your own port number and computer name that you specified in step 2-11, page 18.

• In RM Management Console:
For CC3:

o Update the package list
For CC4:

o Choose File > Import > Package
o Choose Community Connect 3 Package
o Click Browse
o Select the SolidWorks eDrawings 2009.ini you just created 
o Click Open
o Click OK.

[Package]
WIPackage=eDrawings.msi
Description=Package for SolidWorks eDrawings 2009
OS=5.WS
Addcommand=INSTALLDIR="C:\Program Files\eDrawings" ADDLOCAL=ALL
LOGPERFORMANCE=0 SNLSERVER=25734@ComputerName
Dependencies=SolidWorks 2009

Addcommand=INSTALLDIR="C:\Program Files\eDrawings" ADDLOCAL=ALL
LOGPERFORMANCE=0 SNLSERVER=25734@ComputerName
Dependencies=SolidWorks 2009
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Creating the SolidWorks Simulation Packages

SolidWorks Simulation Premium
On a station you can restore:

• Insert the DVD
• Open a command prompt by going to Start>Run>cmd (or in Vista Start>Start Search).  Run the following

commands:
o <drive letter>:
o cd cwwi\COSMOSM\
o msiexec /a COSMOSM_English.msi

• This will launch a wizard.  Click Next
• Tell the wizard you will set up license configuration later.  Click Next
• Enter a path (eg., Q:\Applications\SolidWorks Simulation Premium 2009) and click Install
• The data will then be copied to the folder (this will take a few mins)
• When it has finished, close the wizard
• For CC3:

Edit the file Q:\Applications\SolidWorks Simulation Premium 2009\SolidWorks Simulation Premium 2009.ini and
add to the end of the file the lines:

For CC4:
Create the file Q:\Applications\SolidWorks Simulation Premium 2009\SolidWorks Simulation Premium 2009.ini
with the following content:

Note that the Addcommand line is only one line – it has been split onto two due to its length. Also you will need to change
25734@ComputerName to your own port number and computer name that you specified in step 2-11, page 18.

• In RM Management Console:
For CC3:

o Update the package list
For CC4:

o Choose File > Import > Package
o Choose Community Connect 3 Package
o Click Browse
o Select the SolidWorks Simulation Premium 2009.ini you just created 
o Click Open
o Click OK.

[Package]
WIPackage=COSMOSM_English.msi
Description=Package for SolidWorks Simulation Premium 2009
OS=5.WS
Addcommand=INSTALLDIR="C:\Program Files\COSMOS" SOLIDWORKSDIR="C:\Program
Files\SolidWorks" SERVERLIST=25734@ComputerName
Dependencies=SolidWorks 2009

Addcommand=INSTALLDIR="C:\Program Files\COSMOS" SOLIDWORKSDIR="C:\Program
Files\SolidWorks" SERVERLIST=25734@ComputerName
Dependencies=SolidWorks 2009
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SolidWorks Flow Simulation
On any machine:

• Insert the DVD
• Open a command prompt by going to Start>Run>cmd (or in Vista Start>Start Search).  Run the following

commands:
o <drive letter>:
o cd cwwi\COSMOSFloWorks\
o msiexec /a i386_SolidWorksFlow_English.msi

• This will launch a wizard.  Click Next
• Ignore the serial number prompt and click Next
• Tell the wizard you will set up license configuration later.  Click Next
• Enter a path (eg., Q:\Applications\SolidWorks Flow Simulation 2009) and click Install
• The data will then be copied to the folder (this will take a few mins)
• When it has finished, close the wizard
• For CC3:

Edit the file Q:\Applications\SolidWorks Flow Simulation 2009\SolidWorks Flow Simulation 2009.ini and add to
the end of the file the lines:

For CC4:
Create the file Q:\Applications\SolidWorks Flow Simulation 2009\SolidWorks Flow Simulation 2009.ini with the
following content:

Note that the Addcommand line is only one line – it has been split onto two due to its length. Also you will need to change
25734@ComputerName to your own port number and computer name that you specified in step 2-11, page 18.

• In RM Management Console:
For CC3:

o Update the package list
For CC4:

o Choose File > Import > Package
o Choose Community Connect 3 Package
o Click Browse
o Select the SolidWorks Flow Simulation 2009.ini you just created 
o Click Open
o Click OK.

[Package]
WIPackage=SolidWorksFlow_English.msi
Description=Package for SolidWorks Flow Simulation 2009
OS=5.WS
Addcommand=INSTALLDIR="C:\Program Files\COSMOS" SOLIDWORKSDIR="C:\Program
Files\SolidWorks" SERVERLIST=25734@ComputerName
Dependencies=SolidWorks 2009, SolidWorks Simulation Premium 2009

Addcommand=INSTALLDIR="C:\Program Files\COSMOS" SOLIDWORKSDIR="C:\Program
Files\SolidWorks" SERVERLIST=25734@ComputerName
Dependencies=SolidWorks 2009, SolidWorks Simulation Premium 2009
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SolidWorks Motion
On any machine:

• Insert the DVD
• Open a command prompt by going to Start>Run>cmd (or in Vista Start>Start Search).  Run the following

commands:
o <drive letter>:
o cd cwwi\COSMOSMotion\
o msiexec /a SolidWorks Motion.msi

• This will launch a wizard.  Click Next
• Insert the extended serial number you noted earlier
• Enter a path (eg., Q:\Applications\SolidWorks Motion 2009) and click Install
• The data will then be copied to the folder (this will take a few mins)
• When it has finished, close the wizard
• For CC3:

Edit the file Q:\Applications\SolidWorks Motion 2009\SolidWorks Motion 2009.ini and add to the end of the file the
lines:

For CC4:
Create the file Q:\Applications\SolidWorks Motion 2009\SolidWorks Motion 2009.ini with the following content:

Note that the Addcommand line is only one line – it has been split onto two due to its length. Also you will need to change
25734@ComputerName to your own port number and computer name that you specified in step 2-11, page 18.

• In RM Management Console:
For CC3:

o Update the package list
For CC4:

o Choose File > Import > Package
o Choose Community Connect 3 Package
o Click Browse
o Select the SolidWorks Motion 2009.ini you just created 
o Click Open
o Click OK.

[Package]
WIPackage=SolidWorks Motion.msi
Description=Package for SolidWorks Motion 2009
OS=5.WS
Addcommand=INSTALLDIR="C:\Program Files\COSMOS" SOLIDWORKSDIR="C:\Program
Files\Solidworks" SERVERLIST=25734@ComputerName
Dependencies=SolidWorks 2009, SolidWorks Simulation Premium 2009

Addcommand=INSTALLDIR="C:\Program Files\COSMOS" SOLIDWORKSDIR="C:\Program
Files\SolidWorks" SERVERLIST=25734@ComputerName
Dependencies=SolidWorks 2009, SolidWorks Simulation Premium 2009
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SolidWorks Simulation
On any machine:

• Insert the DVD
• Open a command prompt by going to Start>Run>cmd (or in Vista Start>Start Search).  Run the following

commands:
o <drive letter>:
o cd cwwi\COSMOSWorks\
o msiexec /a SolidWorks Simulation.msi

• This will launch a wizard.  Click Next
• Insert the extended serial number you noted earlier
• Enter a path (eg., Q:\Applications\SolidWorks Simulation) and click Install
• The data will then be copied to the folder (this will take a few mins)
• When it has finished, close the wizard   
• For CC3:

Edit the file Q:\Applications\SolidWorks Simulation 2009\SolidWorks Simulation 2009.ini and add to the end of
the file the lines:

For CC4:
Create the file Q:\Applications\SolidWorks Simulation 2009\SolidWorks Simulation 2009.ini with the following
content:

Note that the Addcommand line is only one line – it has been split onto two due to its length. Also you will need to change
25734@ComputerName to your own port number and computer name that you specified in step 2-11, page 18.

• In RM Management Console:
For CC3:

o Update the package list
For CC4:

o Choose File > Import > Package
o Choose Community Connect 3 Package
o Click Browse
o Select the SolidWorks Simulation 2009.ini you just created 
o Click Open
o Click OK.

[Package]
WIPackage=SolidWorks Simulation.msi
Description=Package for SolidWorks Simulation 2009
OS=5.WS
Addcommand=INSTALLDIR="C:\Program Files\COSMOS" SOLIDWORKSDIR="C:\Program
Files\SolidWorks" SERVERLIST=25734@ComputerName
Dependencies=SolidWorks 2009, SolidWorks Simulation Premium 2009

Addcommand=INSTALLDIR="C:\Program Files\COSMOS" SOLIDWORKSDIR="C:\Program
Files\Solidworks" SERVERLIST=25734@ComputerName
Dependencies=SolidWorks 2009, SolidWorks Simulation Premium 2009
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FURTHER NOTES AND TROUBLESHOOTING
1. Serial Number Errors
2. Network Licenses with Firewalls
3. Dongle Installation Problems
4. Administrative Images
5. Services/Processes still running at install time

1. Serial Number Errors
If you get a prompt box saying your serial number is not a SolidWorks serial number, ignore this message
and click CANCEL

Then click Next
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Please record your new Serial Number.  Click Next to continue installing SolidWorks.

2. Network Licenses with Firewalls
If your computer uses a firewall, you will need to open two ports on the server to allow clients to connect
and obtain licenses.  The default ports are 25734 and 25735 (see page 18).  Set up the ports as follows:

• Firewall software. With Internet firewall software, you must add two ports to your firewall exceptions
list.  See your System Administrator.

• Windows Firewall. If you use Windows Firewall, you must modify ports on the license server to allow
clients to connect and obtain licenses.

To modify ports in Windows Firewall:

1. Go to Start>Run and type in firewall.cpl.

2. If you don’t see the Exceptions tab you may need to click on Allow a program through windows
firewall or change settings, depending on the version of Windows in use.

3. Click on the Exceptions tab, then click on Add port

4. Type a name, (for example, SNL-inport) and your port number (for example, 25734)

5. Select the TCP protocol and click OK.

6. Repeat the process for the second port and then close the Windows Firewall window.
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3. Dongle Installation Problems

USB dongle - when to insert and device drivers.
When you insert the USB dongle for the first time, Windows will detect the device and may try to install
drivers for the device.  You do not want to install drivers for the USB dongle and should choose not to, or
stop Windows from continuing, as they are installed by SolidWorks Installation Manger part way through
the installation.  It is for this reason that we recommend not plugging in the USB dongle until the
SolidWorks Installation Manager prompts you for it.
In this example (Windows Vista) you should click on Ask me again later, you will not be asked again later
unless there is a problem with the installation.

Problems reading dongle
Some users have reported that a message is given during the process of running through the SolidWorks
Network License Wizard at the point of reading the SNL file, indicating that the dongle is not recognized or
the dongle ID cannot be read (or similar).  

This problem most frequently occurs where a remote desktop application such as Remote Desktop
Connection, VNC, Symantec pcAnywhere, is being used.  If this is the case, installing DIRECTLY on the
server should solve the problem.

The problem can also occur if the USB dongle driver software has not installed correctly.  If this is the case,
you should click OK to complete the SolidNetwork License Wizard, then un-install and re-install the dongle
driver software manually as follows:
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To remove the dongle driver software: 
Either:
Use Device Manager and under USB devices remove items with the name HASP, FLEX or Aladdin.
Or:
Open a DOS command prompt and type:
cd C:\Program Files\SolidWorks SolidNetWork License Manager\setup\i386 
Press [ENTER] to change the prompt into that directory, then type haspdinst -r
and press [ENTER].  This will remove the driver. 

To re-install the dongle driver software: 
Open a DOS command prompt and type:
cd C:\Program Files\SolidWorks SolidNetWork License Manager\setup\i386
Press [ENTER] to change the prompt into that directory, then type haspdinst –i

N.B. In some cases the previous command will result in an ‘INOPERABLE BATCH FILE’ error, in which
case you should instead type: hinstall -i  and press [ENTER].  

When the operation completes successfully the LED on the USB dongle will light. 

In a few cases it has been found that Window’s DEP (Data Execution Settings) can be another reason
for communication problems between the SolidWorks Network License software and the dongle.  The
settings should be configured as follows: 

Choose Start > Control Panel > System > Advanced > Performance > Settings > Data Execution
Prevention (DEP), select the second radio button and add sw_d.exe, swlmwiz.exe and lmgrd.exe to the
exception list.

4. Administrative Images

You may experience this error when creating admin images.  It is related to Microsoft components that are
installed with SolidWorks.  You should choose to Ignore the error, which usually occurs because you have a
more recent version of a software component than the installer is trying to use. 
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5. Services/Processes Still Running at Install
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In the event of receiving an error message similar those above, you may need to stop the
swBOEngine process manually.  To do this press CTRL + ALT + DELETE and then click on Task
Manager or Start Task Manager.

Select swBOEngine.exe in the Processes list

Click on the End Process button.

At the next message box, click the 
End Process button



You may also need to stop any SolidWorks related
services, click on the Services tab in task manager.
To stop a running service, select the service in the
list, then right click on it, when the menu pops up
click on Stop Service.  The following services may
be running and causing problems with the
installation:

SolidWorks Licensing Service
Remote Solver for COSMOSFloWorks 2008
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